FIbre Support

Get expert support with your Fibre connection.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Fast Fibre + Boost: high packet loss and duplicate packets

Message 1 of 28

Hi, since I switched from broadband to fast fibre boost, I started having intermittent connection freezes. I noticed these freezes occur mostly when I see bursts of duplicate packets and a high packet loss of >5%. This is the usual output when I ping a highly available internet host from a console:

64 bytes from ( icmp_seq=1283 ttl=118 time=21.5 ms (DUP!)
64 bytes from ( icmp_seq=1283 ttl=118 time=22.2 ms (DUP!)
64 bytes from ( icmp_seq=1285 ttl=118 time=6.65 ms
64 bytes from ( icmp_seq=1285 ttl=118 time=7.23 ms (DUP!)
64 bytes from ( icmp_seq=1286 ttl=118 time=10.8 ms
64 bytes from ( icmp_seq=1290 ttl=118 time=7.38 ms (DUP!)
64 bytes from ( icmp_seq=1290 ttl=118 time=10.1 ms (DUP!)

The Talktalk router is connected directly to the OpenReach master socket, my computer is in a healthy state (normal CPU/Memory usage) and connected directly to the router with a 1.5 meter network cable. The issue happens as well with other cables and for all other devices connected via WIFI.


A BrightSparks engineer came and said he could see an issue outside of the building, I should wait a few days and all should be good again. Unfortunately it didn't get any better. Then an OpenReach engineer came, changed a cable and installed a new master socket. Still the same problem.

The other two flats on my level have Sky fibre and never experienced this kind of issue. Needless to say that I was countless times on a chat with talktalk technicians and tried everything they recommended (removing the NTE5C plate and connect the microfilter cable directly, change microfilter, etc). I added a screenshot which shows the incoming data flow (blue) totally breaking down for a few seconds, and then recovering. The connection breakdown coincides with the duplicate packets and high packet loss (sometimes even >40% in a 5 mins time frame).


Restarting the router often improves the packet loss and duplicate packets, which is enough to get a friction-less connection for some time, but this is definitely not the final solution.


The Boost was not activated immediately and I don't recall of any issues prior to the activation (with broadband or fast fibre without boost).


Is there anyone else experiencing this issue or anyone who was able to fix it?


Thanks in advance!


Community Star
Message 2 of 28

Chat is available on Sunday if you want to try that, after 9am, @andi_b. Links on this page:


Otherwise wait for staff to reach your thread.  They reply Monday to Friday, and will need to be able to identify your account. 


Please complete your community forum profile details. Go via your avatar/name; settings; launch profile wizard; make sure you put in your landline phone number and a fallback mobile phone number; click finish to save. 

Gliwmaeden2, a fellow customer.

Message 3 of 28

I've been numerous times on a chat but that didn't get me any further.  

The download speed collapses multiple times a day, and I run the TalkTalk speed tests on these occasions (see attachment). Interestingly, the upload speed is always stable around 7Mbps.

Is it possible that the local exchange is overwhelmed and therefore starting to drop packets?


Support Team
Message 4 of 28

Hi andi,


Can you please update your community profile to include your:

  • Name
  • Telephone number
  • Alternative contact number

We'll then look into this further. Please do not post this information on this thread. Once you've updated your profile please post in your topic to confirm it's updated. 





Message 5 of 28
My account is now up to date.

Support Team
Message 6 of 28

Hi andi,


Thank you. I've run a test on the line now which hasn't detected a fault and the connection stats look consistent. Does this seem to happen at certain times of the day or at any time?




Message 7 of 28
It can happen anytime, though it usually gets worse towards the end of the day, this morning for example was fine.
When the connection collapses it might take up to 20 seconds to recover. The Mbps values of the Talktalk speed tests I did was in line with the measurements on my machine, which at the time was the only one connected to the router. As long as the packet loss is <1% I don't notice anything, but from 2% it gets very annoying.

Message 8 of 28

Now in the afternoon we're back at ~4% packet loss and duplicates, nothing changed on my machine or in my flat. It's really frustrating having to deal with these connection performance drops and not finding a cause.


>> 608 packets transmitted, 584 received, +7 duplicates, 3.94737% packet loss, time 608246ms


Support Team
Message 9 of 28

Hi andi,


Thanks for the additional information. Can I just confirm, have you ever tested with a different router? If not then we can send a replacement router for testing purposes to rule this out?





Message 10 of 28

I can confirm that the packet loss happens in the morning hours as well, today it reached >20% and the internet connection was unusable at those specific times.

I doubt much it's the router, but it might be worth a try in future if we can't nail down the problem.


Would it be possible to remove the boost first, just to see if the connection gets any better with lower speeds?


Message 11 of 28

Additionally, I remember that I got the router around 3 weeks before fibre was activated. During those two weeks I was able to use the broadband internet connection without issues with the new router.


Support Team
Message 12 of 28

Hi andi,


Could you run another wired and ping and trace route the next time this happens please and post the results into the thread and we can pass this over to our Network Team to take a look at this.


Run a Ping or Traceroute





Message 13 of 28

I run this just now, as I've connection performance issues the whole morning. The performance deterioration and connection collapses are strongly linked to the floods of duplicate packets I see in the console. I don't get a real-time message for packet loss, but I assume it happens at the same time of the duplicate packets.



--- ping statistics ---
29 packets transmitted, 21 received, +4 duplicates, 27.5862% packet loss, time 28156ms
rtt min/avg/max/mdev = 5.815/8.817/26.089/5.183 ms


--- ping statistics ---
217 packets transmitted, 206 received, +5 duplicates, 5.06912% packet loss, time 216484ms
rtt min/avg/max/mdev = 5.581/6.812/27.442/2.646 ms



traceroute to (, 30 hops max, 60 byte packets
1 router ( 0.547 ms 0.675 ms 0.397 ms
2 * * *
3 ( 8.666 ms 6.110 ms 8.656 ms
4 ( 6.094 ms 6.179 ms 6.904 ms
5 ( 7.530 ms ( 8.632 ms ( 7.492 ms
6 ( 7.504 ms ( 8.256 ms ( 7.336 ms

7 ( 6.427 ms ( 6.217 ms ( 6.754 ms
8 * * *
9 * * *
10 * * ( 22.938 ms
11 ( 9.061 ms * *
12 * ( 15.330 ms 7.134 ms
13 ( 6.380 ms 5.644 ms 6.407 ms


Support Team
Message 14 of 28

Hi andi,


Thank you. I've passed this straight over to our Network Team now for further investigation and will let you know as soon as I receive an update back.





Message 15 of 28

It's particularly bad again today. From the traceroute outputs below, it looks like the first hop is over one of your machines: (

Could it be that the host is overloaded or doesn't have enough capacity to serve my requests? The other flats on my floor use another provider and don't experience the same issues.


By searching after the host mentioned above I saw this post from 21-09-2019

which highlights the same issue as mine (it's unclear how it got fixed).


--- ping statistics ---
148 packets transmitted, 118 received, +16 duplicates, 20.2703% packet loss, time 151812ms

rtt min/avg/max/mdev = 81.367/82.799/102.698/2.737 ms


--- ping statistics ---
425 packets transmitted, 389 received, +29 duplicates, 8.47059% packet loss, time 425130ms
rtt min/avg/max/mdev = 5.652/6.502/10.494/0.666 ms


--- ping statistics ---
700 packets transmitted, 600 received, +74 duplicates, 14.2857% packet loss, time 701443ms
rtt min/avg/max/mdev = 4.890/6.680/27.978/3.486 ms


traceroute to (, 30 hops max, 60 byte packets
1 router ( 0.477 ms 3.034 ms 0.618 ms
2 * * *
3 ( 8.876 ms 8.912 ms 10.416 ms
4 * * ( 9.780 ms
5 * ( 8.667 ms ( 8.704 ms
6 * ( 6.792 ms 6.793 ms
7 ( 6.199 ms ( 8.198 ms ( 8.431 ms
8 ( 6.825 ms ( 5.618 ms ( 6.403 ms
9 pg ( 6.326 ms ( 6.848 ms pg ( 5.721 ms



traceroute to (, 30 hops max, 60 byte packets
1 router ( 0.380 ms 0.536 ms 2.400 ms
2 * * *
3 ( 9.071 ms 10.554 ms *
4 * ( 10.646 ms 9.037 ms
5 ( 9.679 ms 9.773 ms ( 9.724 ms
6 * * ( 9.980 ms
7 * ( 5.880 ms ( 5.837 ms
8 ( 7.774 ms ( 6.725 ms ( 7.779 ms
9 ( 5.829 ms 5.014 ms 5.727 ms


Message 16 of 28

Staff reply during the day Monday to Friday,  @andi_b, so this needs to wait for them to reach your thread again. 

Gliwmaeden2, a fellow customer.

Support Team
Message 17 of 28

Hi andi,


Can I just confirm, have you heard from our Network Team since my last post? If not then I will chase for an update on this for you.




Message 18 of 28

Hi Michelle,


I didn't hear anything from the network team, but the connection is stable since Monday, the packet loss is consistently <2% and the connection doesn't collapse anymore, max download speed is good at 60 MBit/s, I didn't experience any single lag when WFH. This is the fist time it's working as expected since I got fast fibre installed in mid July. It would be nice to know what the problem was and how it got fixed, in case it appears again. Obviously the issue wasn't within my building, as nothing changed here.


Let's see if the connection continues to be stable in future, I'll closely monitor it for a while.



Message 19 of 28



I'm really glad to hear this and I'll check in with you early next week to check if the connection/performance has remained consistent.


Thanks 🙂



Message 20 of 28

Ok, unfortunately it didn't last long. The connection performance degraded again, with duplicates and high packet loss, the download speed dropped from 60Mbps to 2-3Mbps, upload speed is good as usual. Nothing changed on my side (1 desktop computer connected to the router via wire, same applications running, same mem/cpu stats).

Below the results from the online Talktalk speed test. Can please someone have a look urgently?








Update 1: same today (Wed 28 Oct 12:07:18 GMT 2020)


60 packets transmitted, 49 received, +13 duplicates, 18.3333% packet loss, time 59243ms
rtt min/avg/max/mdev = 5.237/7.426/25.203/3.158 ms

Update 2: It's good again after restarting the router (Wed 28 Oct 15:02:43 GMT 2020)


4161 packets transmitted, 4157 received, 0.0961307% packet loss, time 4165579ms
rtt min/avg/max/mdev = 4.893/6.973/61.762/2.902 ms


Clearly there's an  issue somewhere and restarting the router is rather a quick-fix than a fix to the real issue.

I'm disappointed with TalkTalk's handling of this case, it's not transparent to me if any investigation was carried or any change was done at all.