FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Fibre speed dropping over 18 months

crazyal
Conversation Starter
Message 16 of 16

My TalkTalk speeds have been getting steadily slower over the last few years. I was originally with BT and connected at 80MB. I started with 76MB with TalkTalk and was happy but now over the last 12 months it has steadily dropped to 70MB.

 

Is there anything I can do/check to ensure this doesn't drop any further or get my top speed back?

Attached is my current router stats.

Thx

 

Al

0 Likes
15 REPLIES 15

Message 1 of 16

Hi Al

 

The router is on its way, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie

0 Likes

Message 2 of 16
OK, I'd be happy with that. I've been using old this model for all this time so using the latest model would be a good test.

Thanks

Al

Message 3 of 16

Hi Al

 

I can send you a router for testing but I can't guarantee if the speed will increase any further (based on the speed range for your line)

0 Likes

Message 4 of 16

So....is that it?

 

Do you consider this now closed considering what I have said previously on this thread?

 

Thanks

 

Al

 

 

0 Likes

Message 5 of 16

Hi crazyal

 

Thanks for confirming your details.

 

The predicted speed range for your line is showing between 73.6 and 55.2mb, with a guaranteed minimum speed of 49.4mb.

 

Your current sync speed of 70.4mb is within the range for your line.

 

Thanks

 

Debbie

 

 

0 Likes

Message 6 of 16

PM reply sent.

 

Thanks

 

Al

Message 7 of 16

Hi crazyal

 

I'm just sending you a Private Message to confirm some details so I can check the predicted range for your line. I can also send a replacement router for testing.

 

Thanks

 

Debbie

0 Likes

Message 8 of 16

Yes, if you could that would be great although as I say I was getting a full 80/20 with BT a few years ago.

I've never had 80/20 with TalkTalk, I think when I first moved to yourselves I got 76/20 which I wasn't bothered about but now it's gone down further it's something I would like to address. 

 

Could I try a new router if all else fails?

 

Thanks

 

Al

0 Likes

Message 9 of 16

Hi Al,

 

Thanks for the update and I'm sorry to hear that there has been no improvement. If the connection has remained stable then I'm not sure why the sync speed has been gradually reducing. Would you like us to check the predicted speed range for your line?

 

Thanks

 

0 Likes

Message 10 of 16

Hi

 

There has been no change to my speed over the last few days using the test socket. It is still at 70mb.

 

Thanks

 

Al

0 Likes

Message 11 of 16

Hi Al,

 

Ok thanks for confirming and we can re-check the connection stats for you on Friday to see if there has been any change at the test socket.

 

Thanks 🙂

 

0 Likes

Message 12 of 16

Sorry, I meant to say I have used the test socket in the past with no real difference  (I said main by mistake).

 

The connection goes off when we have periodic maintenance at the exchange (normally early hours) - this happens a few times a year. I have had the odd drop now and again in the day but a router reset normally fixes that. This happens very rarely, not enough to drop the profile speed I think.

 

However, I will do what you ask and report back here sometime Friday PM.

 

Thx

 

Al

Michelle-TalkTalk
Support Team
Message 13 of 16

Hello,

 

Ok thanks for confirming. If your main socket has a test socket then would it be possible to connect the microfilter, router and phone at the test socket for a few days to see if there is any change in speed? How has the overall performance of the connection been?

 

Thanks

 

0 Likes

Message 14 of 16

Hi Michelle

 

Thx for the quick reply.

 

No, no changes to anything although I will recently admit that I changed the router DNS servers to Google but that was only very recently in the last month. The speed drop was happening way before this.

I have no static or noise on the line and I have plugged into the master socket in the past but no changes there either. 

As I say when I was with BT I had solid 80/20 connection which was fantastic for several years then I changed over to TT.

0 Likes

Michelle-TalkTalk
Support Team
Message 15 of 16

Hi Al,

 

I've run a test on the line now which is clear and the connection looks stable. Is the voice service ok with no noise on the line? Has the equipment set up changed or any new equipment added to the line prior to the speed drop?

 

Thanks

 

0 Likes