FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Frequently need to reboot Wifi Hub

David_A
Chat Champion
Message 28 of 28

We have a TalkTalk Sagemcom Wifi Hub and use the 35Mbps service.

 

At least once a week we lose internet access and need to reboot the router to recover (which it does).

 

We use WiFi but I have found that wired access is also not possible when it fails. I have also tried manually entering numeric ip addresses of well-known sites and these also fail, so it is probably not a DNS issue.

 

The hub led is solid white before resetting.

 

Any recommendations please?

0 Likes
27 REPLIES 27

Skynet_TX
Community Star
Message 1 of 28

A small number of customers have had VPN issues, but it does tend to be people using less common VPN software, we are passing details back to the communities staff each time we see this reported so that the required teams can then investigate.

0 Likes

Message 2 of 28

Hi @Skynet_TX 

Thanks. Are there any reported issues, such as VPN problems, with the release?

0 Likes

Skynet_TX
Community Star
Message 3 of 28

Hi @David_A,

 

The new firmware that fixes the DNS issue is being released in batches to small groups of customers, so it has not yet been generally pushed out to all customers with this router.

0 Likes

Message 4 of 28

Hi, has a firmware update for the TalkTalk Sagemcom Wifi Hub been released yet that fixes the DNS issue?

If so, are any release notes available for the update?

Best regards

David

0 Likes

Message 5 of 28

Hi David_A

 

I also use the Huawei Hub and prefer this router as there are more configuration options in the menu. 

 

Thanks  

 

Karl. 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

0 Likes

Skynet_TX
Community Star
Message 6 of 28

Just saw this mentioned on a old post from last year :

"If the DNS setting on the Internet Connectivity page under advanced settings has the DNS set to "Manually Specify DNS" then the Static DNS Server Configuration is not editable"

 

I don't know if that is true, but if it is, that might be why you can't currently edit the details.

0 Likes

Skynet_TX
Community Star
Message 7 of 28

The  'Internet Connectivity' screen tells the router what IP addresses it should connect to when it is doing DNS lookups, so if your devices are asking your router to do a DNS lookup then the router will go to those IPs to actually access the DNS service you have specified.

 

The  'Static DNS Server Configuration' details are only used at the moment that a device connects to your router, your router will pass those details to the device and tell the device to use those IPs for a DNS server. So if you have the default 192.168.1.1 set on that screen then if you looked at the 'network properties' on your computer you would see that your computer would says its DNS server was 192.168.1.1 (i.e. the router itself), in this scenario your device would send a DNS lookup request to 192.168.1.1, your router would then connect to the 'real' DNS service that was specified on the 'Internet Connectivity' screen to actually do the DNS lookup. But if you have specified the 79.79.79.79 & 79.79.79.80 addresses on the 'Static DNS Server Configuration' screen then if you check the network properties on your computer you would see 79.79.79.79 & 79.79.79.80 specified as the DNS servers. In that scenario your device will not ask your router to do a DNS lookup, but will go straight to those TalkTalk DNS addresses (you could use the OpenDNS addresses if you prefer) to do the DNS lookup.

 

However if you can't edit that screen then there is not a lot you can do and you may be better off trying the Huawei hub, I've tried both and there is really very little difference between them.

0 Likes

Skynet_TX
Community Star
Message 8 of 28

Have you tried using a different browser to see if the router screen works better in that, I've seen a few other people say they could not edit the details on that screen, but it works fine for me (Google Chrome on Windows 10).

 

You just need the check box to be 'On', and then edit the 2 DNS addresses to be the values I mentioned.

0 Likes

David_A
Chat Champion
Message 9 of 28

Hi Debbie

 

I'm cautious about using a Huawei router.

 

Please can you explain to me how the DNS settings are supposed to work on the Sagemcom? I have set the DNS Server settings in the 'Internet Connectivity' page to point to the OpenDNS servers, and my connected devices correctly access OpenDNS. But what is the 'Static DNS Server Configuration' setting in WiFi Hub Settings used for?

 

And why is it set to router's IP address? 

 

@Skynet_TX suggested I disable or change the 'Static DNS Server Configuration' settings but I can't change anything on that page. Clicking on the 'ON' checkbox does nothing. Is that expected?

 

It's a problem for me that the router is so poorly documented. I have a fairly good understanding of how the internet works but I can't find information on what some of the Sagemcom settings actually do. I'd be grateful for some technical explanation of the 'Static DNS Server Configuration' settings please.

 

Are the Huawei DNS Settings more functional?

 

Best regards

David

0 Likes

Message 10 of 28

Hi David_A

 

I'm using the Huawei WIFI hub at the moment and I've not experienced any issues. The connection/speed has been good.

 

In answer to your questions:

 

Do they both have Wi-Fi optimising software? - No the Huawei hub doesn't have WIFI optimisation

 

Do they both support a guest network? - Yes

 

 

Skynet_TX
Community Star
Message 11 of 28

Hi @David_A,

 

The default behaviour is that your devices will be configured to use 192.168.1.1 as their 'DNS Server', so they think the router is the DNS server, but you are quite correct that all the router is really doing is acting as a 'man in the middle' and is just forwarding on that DNS request to the TalkTalk DNS servers (there is another DNS config screen in the router settings where you can specify what IP addresses the router uses to connect to the 'real' DNS servers).

 

By trying this workaround you are just telling your devices to go to the TalkTalk DNS servers directly rather than using the router as the 'man in the middle', and because it appears that the problem relates to the Sagemcom DNS service stopping working, this will hopefully work around the problem, as the router would then no longer be having to act as a DNS server for any of your devices.

0 Likes

David_A
Chat Champion
Message 12 of 28

@Debbie-TalkTalk 

Hi Debbie,

 

Before I decide on the Huawei, please will you tell me the advantages of the Sagemcom vs Huawei?

 

Do they both have Wi-Fi optimising software?

Do they both support a guest network?

Any other differences?

Thanks, David

0 Likes

Message 13 of 28

Hi David_A

 

Would you like me to send a Huawei WIFI hub? 

0 Likes

David_A
Chat Champion
Message 14 of 28

@Skynet_TX Thanks for your reply. You wrote:

 

 by changing the settings as described in my post above it stops your devices using your router as a DNS server

 

At the risk of being pedantic, I can't imagine that the router can actually act as a DNS server - only an external server with DNS services can do that. So I wonder what is actually happening when the 192 DNS server address is specified?

Skynet_TX
Community Star
Message 16 of 28

Hi @David_A ,

 

If you want to try the workaround then as mentioned in my post above you could set them to :

 

Primary : 79.79.79.79
Secondary : 79.79.79.80

 

You will see those addresses mentioned at the bottom of this page, so you know they are genuine TalkTalk DNS servers.

 

Just to be clear, making this change is just a workaround, everything should work with it set to 192.168.1.1, but by changing the settings as described in my post above it stops your devices using your router as a DNS server, and so may work around the problem.

 

The Huawei does not have the Wi-Fi optimisation feature.

0 Likes

David_A
Chat Champion
Message 17 of 28

Hi Michelle

 

The Router Static DNS setting is currently 192.168.1.1.  Please will you confirm what it should be set to?


Before you send me the Huawei, please will you tell me the advantages of the Sagemcom vs Huawei?

 

Do they both have Wi-Fi optimising software?

Do they both support a guest network?

Thanks, David

0 Likes

Michelle-TalkTalk
Support Team
Message 18 of 28

Hi David,

 

Apologies, we have new firmware coming soon for the Sagemcom Wifi Hub which should resolve this particular issue. Would you like us to send the Huawei Wifi Hub? We would also send a router returns bag so that the Sagemcom router can be returned.

 

Thanks

 

0 Likes

Skynet_TX
Community Star
Message 19 of 28

Possible workaround :

 

At present your router will be acting as the DNS server for all of your devices, so when the DNS stops working in your router all of your devices will lose internet access. However you could configure your router so that it just tells all of your devices to use the TalkTalk DNS servers directly, therefore your devices won't use the router as a DNS server, and so shouldn’t be affected if the routers DNS stops working.

 

If you wanted to try this you just need to follow the instructions for the 'Wi-Fi Hub' here (ensure you go to the screen described in this article, as there are two screens in the router where you can modify DNS settings, but you must change the settings on the specific screen described in this article for this potential fix to work).

 

If you have never changed these settings before you will probably find that the primary DNS server is set to 192.168.1.1 (i.e. the router itself). You could change the settings as follows :

 

Primary : 79.79.79.79
Secondary : 79.79.79.80

 

These are the current preferred TalkTalk DNS servers (they are mentioned at the bottom of that webpage so you know they really are genuine TalkTalk DNS servers).

 

IMPORTANT : Having changed the settings you would need to make your devices disconnect and reconnect to the router (you could just reboot the devices or the router). When your devices have reconnected they will be configured to use those two addresses above as their DNS servers. So from that point on the devices will use the TalkTalk DNS servers directly rather than going via the routers DNS service.

 

Making this change may well resolve the issues for you, but if you do ever want to 'undo' this change all you need to do is put the old values back into that screen, or you could just factory reset the router by holding in the pinhole reset switch on the back for over 10 seconds, as that will return all settings back to their initial defaults.

0 Likes

Skynet_TX
Community Star
Message 20 of 28

The new firmware is being tested at the moment, I believe they hope it will be released later in July, but that does depend on successful testing, so no date has been confirmed yet.

 

In the short term the easiest 'fix' is for the staff here to send you a replacement router of a different type (the Huawei Hub), I'll escalate this post for the staffs attention (as it has been a long time since the previous post), so they will hopefully be able to pick this up tomorrow.

 

However if you are comfortable with changing some settings in the Sagemcom then there is a chance that will stop the problem from happening until the new firmware is released (it has resolved the issue for me). I'll paste the details in a new reply below, so if you wanted to try this then it may work around the issue with the Sagemcom, but staff should also reply tomorrow and may be able to send you a Huawei hub anyway.