FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Help Please with broadband speed

redmikekite
Conversation Starter
Message 19 of 19

Hi recently I have been having issues with my internet speed dropping into my router, Its always a constant 40mbps with a speedtest results of 37mbps with an ethernet to pc connection and around the same or slightly less over wifi, I currently use a netgear nighthawk which is 3 years old now this has been going on for about a month and I usually have to reset the router and it comes back but today its got worse so trying to rule out the connection I have connected a brand new talktalk router which I received after renewing my contract in june. So the speed going into the talktalk router after setup was 19.5mbps so I rebooted and the speed going into the talktalk router has jumped up to 40mbps which is great but when i do a speedtest over ethernet my download speed has dropped to around 18mbps which i cant understand as the speed into the new router is 40mbps and previously the down load has always been around 37mbps via speedtest and talktalk speedtest. Does any one have any ideas? I am stumped i have reset my pc network settings and checked everything. I have a fairly new high spec gaming pc which I built my self which has two network work adapters and I have tried both. any help would be greatly appreciated, its strange as my connection and speeds have always been constant which is why I stay with talktalk.

0 Likes
18 REPLIES 18

Message 1 of 19

Hi Mike

 

Thanks for keeping us updated 🙂

 

I'm glad to hear that the connection has remained stable. If you do experience any further issues then please let us know.

 

Debbie

0 Likes

Message 2 of 19

Hi Debbie

new router connected had a few issues so as my openreach mk4 socket has a built in filter i took the front off and connected it to the test socket with the new micro filter provided and so far so good its been completely stable so I will leave it like this and if it continues to be fine I will replace the mk4 socket front. once again many thanks for the quick response as I said previously I believe the community is the way to go if you need help.

 

Kind regards

Mike

Message 3 of 19

Hi Mike

 

That's great 🙂

 

Thank you for your kind words, It's appreciated 🙂

 

Please let us know how you get on.

 

Thanks

 

Debbie

0 Likes

Message 4 of 19
Hi Debbie
thanks for your help just had notification from yodel delivering today which will be the router, my microfilter is built into the socket so i will use the test socket with a microfilter and see what happens. Many thanks again for your help, i find the talktalk community a great asset for help and adivice, its really appreciated in theses difficult times.

regards
Mike

Message 5 of 19

Hi Mike

 

Thanks for your reply. Yes this could be the router or the microfilter.

 

Hopefully you will receive the replacement router today.

 

Debbie

0 Likes

Message 6 of 19
Hi Debbie
im at work at present but funny you should say that when i disconnected it yesterday the noise did go when the router was unplugged from the socket so would this indicate its the router then ?
regards
mike

Message 7 of 19

Hi Mike

 

Is the noise still present on the line if you remove the router? Is the noise still present at the moment?

 

Thanks

 

Debbie

0 Likes

Message 8 of 19
Hi Debbie
No not yet
Regards
Mike
0 Likes

Message 9 of 19

Hi Mike

 

Have you received the replacement router?

 

Thanks

 

Debbie

0 Likes

Message 10 of 19

Hi Debbie

my internet stopped completely this evening started working again after router reset but speed has dropped in to router also there is alot of cracking noises on the phone line which i did not have before, any ideas?

 

regards

 

Mike

0 Likes

Message 11 of 19
0 Likes

Message 12 of 19

Many thanks Debbie

I will let you know how I get on I really appreciate your help

 

regards

 

Mike

Message 13 of 19

Hi Mike

 

The router is on its way and a returns bag for your current router.

 

Please allow 24-48hrs for this to arrive. Let us know how the connection compares with this router.

 

Thanks

 

Debbie

Message 14 of 19

Hi Debbie

yes that would be most helpful would you like me to return the new talktalk router I received when I renewed my contract? that model is a sagecom fast5364-3.T8 serial number is N7200654N006637

 

Regards

 

Mike

Message 15 of 19

Hi Mike

 

Apologies for this.

 

Would you like me to send a different make and model of router for testing to see how the connection compares?

 

Thanks

 

Debbie

0 Likes

Message 16 of 19

Hi Debbie yes it usually does and seems to work fine for a while sometimes it’s good for a couple of weeks then plays up again hence swapping out the router for a new talktalk one but this still had the same issues I had a family member who works for a well telecommunications company check my wiring inside my house and all is good so I’m really stumped but so far it’s running ok but I’m not sure how long this will last. I had a couple of issues in the past two years which were problems at the cabinet. So I don’t know what else to do

 

regards 

mike 

0 Likes

Debbie-TalkTalk
Support Team
Message 17 of 19

Hi redmikekite

 

I'm really sorry to hear this.

 

Just to confirm, does the speed always increase after the router has been rebooted?

 

Thanks

 

Debbie

0 Likes

Skynet_TX
Community Star
Message 18 of 19

Hi @redmikekite,

 

Have you tried switching the router off for over 30 minutes, then when you switch it back on it will start a new 'session' in the street cabinet. 

 

I've had this exact same issue when moving between two different models of TalkTalk supplied router, the new router will sync at 40 but only give me 28 in throughput until I force a new session with a +30 minute shutdown.