FIbre Support

Get expert support with your Fibre connection.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Help connecting second router to TalkTalk Hub

First Timer
Message 4 of 4

I have recently moved into a new house which has a little office down the end of the garden. The previous owners had wired in an ethernet cable to run from the router based in the house down to the office.

I have purchased a router online in the bid to get internet signal in the office. I presumed it would be as simple as connecting the ethernet cable as an output to the Talktalk router, and as the "internet" input of the new router. But it seems this is not the case.


The office router is a TPLink Archer A7 TC1750 if that helps.

If I plug my laptop straight into the ethernet in the office then it is able to use the internet, so signal is getting to the outhouse.

But when I plug in the router, there is no connection. The internet light on the router in the office occasionally turns orange for a few seconds as if it picks up the internet signal briefly, and then goes blank for a while. 


I am not sure whether I need to adjust settings in either the TalkTalk Hub, or the office router, or both, but something is wrong. Would very much appreciate any assistance on this. I have searched for guides for both TalkTalk routers and TPLink routers but it's difficult to know where to be focussing my efforts.






First Timer
Message 1 of 4


Thanks for your prompt reply. I've tried both options but neither have worked sadly.


I've brought my Archer inside and connected to the home router with another ethernet cable. (Ethernet output to internet input). The Archer now has a green light for the internet symbol, which I find odd. 

It suggests the long ethernet is the issue, but the internet tells me it should be fine for up to 100m, which we are definitely well under. I'll try doing a speed test in the office when I connect a laptop directly to the cable to see if it's a bad connection. 


Message 2 of 4

@DanGa the Archer has an ACCESS POINT MODE , so try that first !


Connect LAN to LAN, both yellow.


If that does not work, try this.


Log in to the Archer interface whilst it is NOT connected to ANYTHING except the device you are using to make the changes.

Disable DHCP

Give it a fixed IP address of

Save the changes.

Log out


Log in to your HUB

Check the IP address range is set to to (that is the default I believe, but change if necessary)

Save changes.

Log out.


Now the important bit, connect the extension cable to a LAN port on your HUB and the other end to a LAN port on the Archer.


You should now be able to access the internet by connecting to the Archer.


You will now be able to log in to the Archer interface at + password and change WiFi channels as you need.


I had issues with some network setting on Windows 10 laptops that stopped internet access when connected to the remote access point, but that was nothing to to with the way I connected them, an old XP laptop worked.


Windows Troubleshooter solved it, so I cannot say exactly what it was.


First Timer
Message 3 of 4

In terms of solutions, I don't mind if the office router gives off the same signal as my TalkTalk Hub, or if it generates it's own separate signal. Will accept whichever is simpler.