FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How do I update broadband to latest version?

Jerzy2
Popular Poster
Message 4 of 4

When doing a service check I recevied a message saying "you have a sagemcom-FAST5364 but the software needs updating to the latest version" please help.

0 Likes
3 REPLIES 3

Message 1 of 4

sorry for bumping again, still need help

0 Likes

Message 2 of 4

sorry for bumping, still need help!

0 Likes

Jerzy2
Popular Poster
Message 3 of 4

still need help.

0 Likes