FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Hub software version

pbpb1
First Timer
Message 9 of 9

I had to reset my hub black to factory defaults last week after it completely stopped working (couldn't even access its web interface). Am now wondering if I need to get its firmware updated as the firewall / port forwarding funcationality isn't working properly. Current version is SG4K100130 - is this the latest or old?

0 Likes
8 REPLIES 8

Message 1 of 9

Hello,

 

Would you like us to send a replacement router for testing purposes to rule this out? We would also send a router returns bag so that one of the routers can be returned.

 

Thanks

 

0 Likes

KeithFrench
Community Star
Message 2 of 9

I wonder if your router is faulty, mine forwards fine on various 192.168.x.0 networks fine & also on a network 10 address.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

pbpb1
First Timer
Message 3 of 9

I am trying to configure both port forwarding and also set firewall rules, i.e. two separate things. I had to reset the router to factory defaults as it was completely non-functional. After resetting I changed the routers IP address to match the rest of my network (i.e. not 192.168.1.1). The port forwarding page then did not work (I got a red error box with "..something wrong happened.." every time I added a rule. I found the post linked above which talked about this problem, and did what was suggested, which then allowed me to set port forwarding rules (which are now working). However, the firewall configuration does not work, as I can't select TCP/UDP or any services (both dropdowns are blank, no entries) as per above image.

0 Likes

KeithFrench
Community Star
Message 4 of 9

Port forwarding does work in V130. Your problem is that you are doing it in the wrong place. You do not configure it via the firewall at all. Please undo all of the configuration that you have done to the firewall.

 

You need to do it from the Port Forwarding page & add a new rule, which can be reached by going to:-

 

Dashboard > Manage my devices > Advanced Settings

Click on the device that you wish to forward to.

Then go to:-

Port Forwarding > Add Rule

This will populate the Internal Host box of the Add Rule screen with that device's IP address.

 

Alternatively, you can do it from:-

 

Dashboard > Manage my devices > Manage Advanced Settings > Access Control > Port Forwarding. Then click Add Rule > Add Rules Manually



Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

pbpb1
First Timer
Message 5 of 9

Hi Keith. I need both portforwarding and firewall rules.  To recap, if the hub has a LAN IP other than the default (I think thats 192.168.1.1) then the UI won't let you add any port forwarding rules. The fix for this described in the post linked above works, but I then found the firewall page in the UI (add firewall rule) doesn't let you choose TCP / UDP for protocol (i.e. the dropdown list is blank, as is the Service dropdown), see below:

pbpb1_0-1642854200235.png

I realise making the change as per the other link may well have caused this - I would be happy to again factory reset, but seems there is a bug which means you can't have port forwarding when the routers lan IP is not the default one - the actions given in the other link sorts that out but not the firewall issue. Any thoughts appreciated. Thanks

0 Likes

KeithFrench
Community Star
Message 6 of 9

If you would like to send me a screenshot of the PF rule (there is no need to touch the router's firewall configuration at all) I will help you.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

pbpb1
First Timer
Message 7 of 9

Hi Chris, It wouldn't let me add any port forwarding rules (came up with red error box "...something wrong happened" each time). I saw this post: https://community.talktalk.co.uk/t5/Broadband/Fast-5364-port-forwarding-error/m-p/2627018 which talked about this problem (when the router IP address is not the default one, as is the case for me), so did what was suggested there (using the Chrome console). This fixed that problem (port forwards can now be added), but now when trying to add firewall rules the dropdowns for 'service name' and 'protocol' have no entries (e.g. I can't select TCP or UDP for protocol). Maybe there are other things which need to be added (like in the first post) due to me having a router IP address which isn't 192.168.1.1?

0 Likes

Chris-TalkTalk
Support Team
Message 8 of 9

Hi pbpb1,

 

130 is the latest firmware version. Could I ask what problems you are experiencing with the firewall and port forwarding?

Chris

0 Likes