FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

I have strong broadband speed but weak wifi in house

slimtrader
Chatterbox
Message 10 of 10

Hello

 i have been customer for a while and im on faster fibre with speed boost and when i do broadband speed check it around 65 but the actual wifi im getting is poor even on mobiles in the house we get 1 bar of signal etc and using ps4 or xbox can be laggy , i have the talktalk hub and on a wifi analyzer on phone it shows 2 channels a 2,4ghz and a 5ghz ,says we are connected to the 5ghz what could be causing the slower wifi speeds

0 Likes
9 REPLIES 9

Debbie-TalkTalk
Support Team
Message 1 of 10

Hi slimtrader

 

Would you like me to send a replacement router for testing to see how the connection compares?

 

Thanks

 

Debbie

0 Likes

Message 2 of 10

You have not split the SSID names and are still connected to the 5 Ghz band.

 

Those figures in dBm are the signal strengths being received and reported by your device, they do not indicated speed.

 

Whilst very low signal can affect speed, as you are on what looks to be a very clear 5 Ghz channel with a decent signal that should not be an issue.

 

 

 

 

0 Likes

Message 3 of 10

this is my result in front of the wifi router supplied by talktalk i feel this should be a lot higher

0 Likes

Message 4 of 10

Hi i have made the changes but if you look at the wifi analyser download i attached earlier that was taken in front of the router box..seems very low i think is this normal as still get lots of lagging on ps4 even though i get 80mbps into the property it doesnt seem to translate to my wifi..could i have a faulty router ?

0 Likes

Michelle-TalkTalk
Support Team
Message 5 of 10

Hi slimtrader,

 

Please let us know how you get on and if you need any assistance 🙂

 

Thanks

 

Message 6 of 10

Make sure the 2.4 and 5 Ghz SSIDs have different names, you may need to go into the router's settings page to do this, follow the instructions below.

 

https://community.talktalk.co.uk/t5/Articles/Split-your-router-s-SSID-wireless-network-name/ta-p/230...

 

Once you have done that, go to the WiFi settings on your devices disconnect from the 5 Ghz SSID and untick any automatic connections boxes.

 

Reconnect them to the 2.4 Ghz SSID and see how it goes.

 

 

 

 

Message 7 of 10

This is my analyser data not sure how to read it

0 Likes

Message 8 of 10

How do I switch to the 2.4ghz channel 

0 Likes

martswain
Philosopher
Message 9 of 10

2.4 Ghz channels are much better at penetrating walls and floors, so you may get better signal strength if you change your connections to that band.

 

If you have close neighbours download a WiFi analyser and make sure you set your router to broadcast on the least congested channels, use the analyser in the area where the connection is problematic, not just next to the router.

 

0 Likes