FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Incoming port 80/443

Ligan
Team Player
Message 27 of 27

Having some issues with fibre and and not receiving data even though port 80 is forwarded correctly so I just wanted to check if anyone else has had an issue with a webbserver and port 80 or if talk talk block this? Cheers

0 Likes
26 REPLIES 26

Piethorne
Chat Champion
Message 1 of 27

It can take a few minutes for changes to propagate through nameservers. I've set up webservers on VMs using non-standard binding ports and forwarded ports + masked / redirected URLs before, and have sometimes had enough time to make a brew and clear out browser caches before the URLs became active.

I'm just a customer who might be able to help, not official help & support.
0 Likes

Message 2 of 27

I think I was just being impatient, it has worked and now everything is working as intended! What a sigh of relief. 

0 Likes

KeithFrench
Community Star
Message 3 of 27

I do not have Nginx proxy to try, so sorry I can't help you where that is concerned.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 4 of 27

I've just tried this but unfortunately didn't work, I went to Local DNS > DNS Records and entered my website address and the ip for Nginx proxy that it's on 192.168.1.254 is that right?

0 Likes

KeithFrench
Community Star
Message 5 of 27

Hi @Ligan 

 

Just out of interest, I have now got a Linux Mint running in a VM with Oracle VirtualBox and have forwarded FTP to a server on there & it all worked even with the Linux Firewall configured.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

KeithFrench
Community Star
Message 6 of 27

Very few TT routers support NAT loopback - I didn't realise you were trying to test it like that. Drop the WiFi connection on a smartphone & use mobile data is a very good way to test it.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 7 of 27

The port forwarding is working so thank you for all your help Keith, you've been great. As per the commenter above the router doesn't seem to support NAT Loopback so I'll set up pihole again and add a DNS entry for the website

Message 8 of 27

Perfect, thank you i'll get that sorted

0 Likes

Message 9 of 27

I ran into this problem...  it's because the Sagemcom router doesn't support NAT loopback.

 

You mentioned you use pi-hole - the fix for me was to add a DNS entry for the external address in the 'Custom DNS' section, and point it to your local LAN IP address for the site (192.168.1.240).

KeithFrench
Community Star
Message 10 of 27

So are you saying that the port forwarding is OK now, or is it that Wireshark is working? If the former, there is no need for me to see your trace.

 

When in your VM, do not forget that you will need to connect to port 8091.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 11 of 27

Hi Keith,

 

sent a couple messages last night and also tried to private message you. I just had to run it as  sudo and I got the trace, can upload tonight if needed but .... I THINK IT WORKS!

 

So stupidly I never actually tried to connect outside to the websites outside of my network.  They do appear correctly it's just that when I'm inside my own network I can't connect to them. From what I've been trying to read up on it could be something to do with the router and maybe having to move to split dns or I have to edit the dns server to add the website and associate it with its internal IP.

 

Not sure how to do either of those things or which one is correct mind you.

 

 

0 Likes

KeithFrench
Community Star
Message 12 of 27

None of those are showing any activity, so Wireshark will not be able to capture on them. What interfaces are listed on the VM's OS?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 13 of 27

Not sure which of these interfaces to run it on, any ideas? Cheers!

 

2021-09-29 19_05_41-pve - Proxmox Virtual Environment - Brave.png

0 Likes

KeithFrench
Community Star
Message 14 of 27

I will edit your post to remove the screenshot as it gives away your name & the company you work for. I will delete the trace as well to protect your privacy.

 

Run Wireshark on the VM itself, the interface that Wireshark needs to be set to capture on is the network adapter in the VM. What is the IP address of the device you are trying to forward to & is it still TCP port 8091?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 15 of 27

Hi Keith,

 

Wireguard server is on the same VM as Nginx, vm is set to use vmbr0 which is a virtual bridge. I've run wireshark while I'm connected through my VPN at another location, presume that should still have the same data as it's routed through my home network.

 

I also wasn't sure which of the below options to select so I just went with "Ethernet"

 

Hope this helps! Thank you

 

 

 

edit : in hindsight I don't think this info will be any good, I'll run it again when I get home tonight

0 Likes

KeithFrench
Community Star
Message 16 of 27

Is Wireguard on the host or the VM, if the VM & you can now forward a port to that, anything else would seem like it would be down to the application.

 

However, Wireshark will enable me to prove what is going wrong, I will PM you with details on how to use it.

 

Please can you confirm what mode the VM's network adapter is configured as.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

demulv
Team Player
Message 17 of 27

Are you able to open the site from your internal network using http://192.168.1.240:8091 ?

0 Likes

Message 18 of 27

Thank you for your help so far by the way Keith. 

 

I've re-done the VM entirely, reset my DNS back, removed my PiHole and started from scratch. I've installed Wireguard and forward the port for that and can confirm that works all okay.

 

I've redone the port forwarding rule for the web server and kept it just on port 80 and I've set it as TCP-UDP instead of just TCP.

 

Port 80 and 443 are showing as open in portcheck tool

 

The websites themselves  are on Freenom and Bluehost.

I've got one trying to point with a CNAME record to my dynamic DNS No-IP and I've got 2 free ones on freenom trying to point using A records to my dynamic ip which I know will change but I just wanted to see if there was an issue with the dynamic dns system. 

 

I've installed Wireshark but I'm not quite sure how to use it, is there a specific test you'd like me to run on it?

0 Likes

KeithFrench
Community Star
Message 19 of 27

No there is nothing wrong with the port forwarding on the router at all. This is what I have just replicated:-

80 to 8091 pf rule.png

 

Testing port 80 (with 8091 open on my PC) reports open:-

80 to 8091 port checker.png

 

When port forwarding to a VM, you must look carefully at your VM's networking configuration. When I have used VirtualBox, you have to set the VM's networking configuration into Bridged Mode, if you want to port forward to it. This gives the VM an IP address on the same subnet and you can then forward to that address from the port forwarding rule on the router.

 

Can you run Wireshark on the VM, if so get me a trace from that & I will check it for you?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 20 of 27

Webserver is running in a docker container on an Ubuntu VM inside Proxmox.

 

I've just changed the port forwarding rule to translate port 80 to 8091 and push to 192.168.1.254 which is the ubuntu VM itself but still noting. Port check tool is showing nothing listening on 80

 

I'm convinced it's a port forwarding issue since I can access the webserver/reverse proxy internally just not externally. 

 

No installed firewall other than whatever is be default on the router

0 Likes