FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Iptv seems blocked

Tonygoole
Popular Poster
Message 24 of 24

I have a Samsung 2020 smart TV. 

 

I'm using an App called NetIptv to watch IPTV or im trying to.

 

If I use TalkTalk as my Internet provider I cant get any channels via the app.

 

I have been through this issue with Samsung, who suggested try connecting thru your mobile hotspot to your EE Internet provider and everything works perfect.

 

So the issue has to be related to Talk Talk..

I have spent a couple of hours on the phone with their Tech guys, who have no grasp of the English language and what I am telling them. One guy who was great suggested port forwarding and I need to find the port forwarding details for my TV. Then he said I cant be anymore of a service to you. Thanks for you call.

 

I looked in to this and apparently the TV sets this automatically.

 

I have the same issue on my PC using TalkTalk also, but I just connect to the Internet via a VPN and everything works great. I dont know if that will help to narrow down the problem. 

 

Has anyone had the same problem and possibly point me in the right direction..

Tony
0 Likes
23 REPLIES 23

Message 1 of 24

OK thanks. I'm not really sure what else to suggest, this isn't something that we specifically support, is there no other app that you could try that performs a similar function?


Chris

 

 

0 Likes

Message 2 of 24

Hi Chris

 

I click on the app on the tv and it opens, the channel list is there. I click on a channel and it tries to load it.

 

Then it just says try 1, try 2 etc

Tony
0 Likes

Chris-TalkTalk
Support Team
Message 3 of 24

Hi Tony

 

I can't see anything to indicate that we block this. Could you explain exactly how far you get before the app appears to be blocked

 

Has this ever worked on your TalkTalk connection? When did you first try it?

 

Thanks

Chris

 

 

0 Likes

Message 4 of 24

Cheers Rbaker

 

It works with EE perfectly and on my gf's when she connect my TV via a hotspot on her phone using o2. I have a VPN but I don't know how to set it up on the smart tv, there is no app for it.

 

Tony
0 Likes

Message 5 of 24

There is a court order in place to block iptv services because they stream illegal content.  Talk Talk are forced to enforce the block together with the rest of the "big six isps".  Your iptv provider will be blocked 30 mins before, during and 30 mins after Premier League matches.  So on a weekend, pretty much blocked. This means that their servers will be invisible to you and you will not be able to log in.  The solution is to either leave the big six isps or subscribe to a vpn if you believe your iptv service to be legitimate.

https://www.premierleague.com/news/787656

0 Likes

Message 6 of 24

Good afternoon Michelle 

 

Updated

Tony
0 Likes

Michelle-TalkTalk
Support Team
Message 7 of 24

Hi Tony,

 

Can you please update your community profile to include your:

  • Name
  • Telephone number
  • Alternative contact number

We'll then look into this further. Please do not post this information on this thread. Once you've updated your profile please post in your topic to confirm it's updated. 

 

Thanks

 

0 Likes

Message 8 of 24

Good morning Fritz

 

I gave it a try last night, still no luck. But a channel worked for about 2 seconds everytime I changed the dns value. Then stopped 

Tony
0 Likes

Message 9 of 24

I don't have a smart tv but if you can then try just the TV first then on the router as well...Anything like Google, OpenDNS, Cloudfare will do. It may make no difference but if TT are blocking it as part of a group policy (ISP's have a legal obligation when it comes to streaming sites) then it might bypass that. You can always change it back after if it makes no difference. 

 

The other thing you might try is to switch Homesafe on again, wait a few minutes for everything to update and then turn it off again. 

 

Fritz

 

EDIT: sorry should have said Google "Google DNS" "OpenDNS" or "CloudfareDNS" to get the addresses. I'm guessing there'll be a setting on the TV network settings that says obtain DNS automatically or enter manually and you need to enter manually. Same on the router.

0 Likes

Message 10 of 24
Hi fritz what do I change them to? On the router or TV?
Tony
0 Likes

Message 11 of 24

Change your DNS settings and see if it connects. 

 

Fritz

0 Likes

Message 12 of 24
Hi Chris

It tries to load the channel and says channel loading then channel error
Tony
0 Likes

Message 13 of 24

Hi Tony,


Does the app give an error when you try to use it?

Chris

0 Likes

Message 14 of 24

Hi Debbie

 

Its the Sagecom fast 5364-3. T8

 

Thank you 

Tony

Tony
0 Likes

Message 15 of 24

Hi Tonygoole

 

Apologies for this.

 

Which router are you using? (make and model)

 

Thanks

 

Debbie

0 Likes

Message 16 of 24

Hi Debbie and Michelle 

 

I have tried router power down and in still getting the same problem. 

Tony
0 Likes

Message 17 of 24

Hi Tonygoole

 

How are you getting on?

 

Thanks

 

Debbie

0 Likes

Message 18 of 24

Hi Michelle 

 

No I have not tried that yet, soon as I get home I will try it and let you know thank you for your help

Tony

Message 19 of 24

Hi Tony,

 

I'm sorry to hear this. Just to confirm, have you also tried powering down the router for a full 30 minutes and then retested again as this will reset the current session?

 

Thanks

 

Message 20 of 24
Still no luck
Tony
0 Likes