FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MS Remote Desktop over OpenVPN

gh2609
Popular Poster
Message 28 of 28

Here’s the problem:

I have a Sagem router (TalkTalk supplied) and via WiFi connection, trying to use MS Remote Desktop over OpenVPN with an iPhone. This works very well via a Windows 10 laptop, desktop and Android tablet, but will not work with the iPhone. I tried three separate iPhones, all of which will connect to OpenVPN server using iPhone OpenVPN client, but then get no response trying to connect using MS Remote Desktop client.

 

The iPhones will however connect through OpenVPN and MS Remote Desktop via a cellular connection. 

As a further diagnostic step, I also temporarily changed router to one previously supplied by TalkTalk (D-Link), but this gave exactly the same result.

 

I even tried to connect using iPhone at another property using TalkTalk, but this also failed.


In every case using the iPhone, a ping or traceroute to the Remote Desktop host returns no response, even though an OpenVPN connection has been established.

 

Any ideas will be much appreciated.

0 Likes
27 REPLIES 27

Message 21 of 28

Hi @gh2609

 

Thanks, Glen for confirming this. I assume that iPhones still do not support any kind of pcap capture technology, so there is no way I can find out what is going wrong. All I can therefore suggest is that this is passed over to the TalkTalk products team for testing.

 

@Michelle-TalkTalk please can you arrange this?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 22 of 28

Hi Keith,

 

Thank you for offering to help. To summarise, the details below show the connectivity issues. The OpenVPN server is located at work and all relevant ports ports have been confirmed as open.


Connection required is to use MS Remote Desktop over OpenVPN.

 

Any iPhone

Using TT Fibre+Router+WiFi.

Using TT Fibre+Router+Ethernet.

Using Virgin Fibre+Router+WiFi.

Using cellular network.


Android phone 

Using TT Fibre+Router+WiFi.

Using cellular network.

Windows 10 

Using TT Fibre+Router+WiFi. 

Using cellular (tethered).

 

So the issue appears to be associated with a combination of iPhone through a TT fibre and router.

 

Regards

 

Glen

 

 

 

 

 

 

 

0 Likes

Message 23 of 28

Hi @gh2609 

 

@Michelle-TalkTalk has asked me to help you but I do not have any Apple products to test with.

 

However, I might be able to help on a more generic basis but first I need to understand better your scenario.

 

Is open VPN installed as a client on the working desktop, laptop, Android, is it also installed in the same manner on the iPhone?

 

Where is the PC you are trying to RDP into, is this at work or at home? Where are the iPhone, laptop, desktop & Android when you try to RDP into this PC?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Michelle-TalkTalk
Support Team
Message 24 of 28

Hi,

 

@KeithFrench - Is this something that you would able to offer any advice on?

 

Thanks

 

fr8ys
Community Star
Message 25 of 28

Thanks for the update.

 

Hopefully the OCE may have a solution for you.

 

Is there an Apple forum where you can also ask in case someone there had a similar problem?

Please remember to mark Solved Posts with Best Answer. Doing so helps other customers and saves TalkTalk's Support Team time by only looking at unsolved topics. Thanks, Steve (a fellow customer).

Message 26 of 28

The scam filter is off and has been so for at least the past year.


I have narrowed down the problem to a combination of using an iPhone and TalkTalk. The MS Remote Desktop over OpenVPN works fine with Windows 10 and Android using TalkTalk. 

Further to my earlier post, I have successfully connected to the MS Remote Desktop host with iPhone using a Virgin Media fibre connection and WiFi. As soon as I use the same iPhone over a TalkTalk fibre connection, the MS Remote Desktop client will not connect.

 

So still puzzled as to what the problem is.

0 Likes

fr8ys
Community Star
Message 27 of 28

Hi,

 

Have you tried turning scam protection off?

 

If you go to my account, you can turn this off there.
To do so:
1 Log in to MyAccount
2 Select My Services
3 Select View HomeSafe settings
4 Select OFF and confirm when you see the pop-up window

You may also need to disable any pop up blocker you may have installed

Good luck.

Please remember to mark Solved Posts with Best Answer. Doing so helps other customers and saves TalkTalk's Support Team time by only looking at unsolved topics. Thanks, Steve (a fellow customer).