FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

More DNS Problems with Sagecom FAST 5364-3 with SG4K10002816t Firmware

Pedant
Conversation Starter
Message 11 of 11

After years of stable service from my TalkTalk routers I started having problems early in March. The problems manifest as "no internet connection" so that no Wifi or ethernet connected devices can refresh old pages or connect to new pages. Communication between devices continues to work OK and the VDSL connection is reported as 80 and 20. The problem has recurred  at intervals of between 7 and one day. Until today the only way I could resolve it was to reboot the router (either power cycling or from the router GUI).

 

About 10 days ago I had 3 occurrences in 3 days so I did a factory reset. Since then the problem has happened twice. The first time I power cycled the router to recover. Today I managed to recover it by setting the router's DNS to manual and using Google's 8.8.8.8 & 8.8.4.4 DNS'. I then set DNS back to auto and it selected 79.79.79.79 & 79.79.79.80 again and it is still working.

This seems to be the same problem that I've read about on this board where the firmware gets its DNS use confused until a change to the DNS is requested.

I'd really prefer it if TalkTalk could fix the firmware problem, but please advise what I should do to get back to my reliable router.

 

0 Likes
10 REPLIES 10

Pedant
Conversation Starter
Message 1 of 11

Is there any news of the corrected firmware's availability or even a date for knowing its availability date?

0 Likes

Message 2 of 11

Hello,

 

Apologies for the delay. During the final testing phase an issue was identified so this has to be resolved and retested before we can roll this out. It's now looking like it will be next month at the earliest.

 

Thanks

 

0 Likes

Message 3 of 11

Is there any news on the new Firmware? If not, when do you expect news?

0 Likes

Michelle-TalkTalk
Support Team
Message 4 of 11

Hi Pedant,

 

Ok no problem 🙂 Once it's available then we will start rolling it out automatically.

 

Thanks

 

0 Likes

Message 5 of 11

Michelle,

 

Thanks - that's fine with me.

 

One, hopefully final, question: what will happen when the new firmware is ready? Will it be automatically sent to my router or will I need to do something to to download and install it?

0 Likes

Michelle-TalkTalk
Support Team
Message 6 of 11

Hi Pedant,

 

We've been advised that the firmware should be ready at some point next month. If it does become really frequent then please post back here and we can send the replacement router for you ASAP.

 

Thanks

 

0 Likes

Message 7 of 11

Michelle,

Thanks for your prompt reply.

Do you have any idea when the new firmware will be available? I'm happy with the sagemcom router apart from this problem and the problem is mostly infrequent so I'd be happy to cope with it for a few weeks if the firmware fix would then be available.

If the problem starts to happen again every day I'd quickly want to try the huawei router.

 

Would it be best for you to send the Huawei router for me to have ready in case the problem frequency increases. I could then send it back when the new Sagemcom  firmware has been working for me for a few weeks.

 

Alternatively we could leave this thread open so that, if I lose patience with the sagemcom, before the new firmware is available, you could quickly send the huawei.

Let me know what you think is best.

Thanks again for you help.

 

0 Likes

Michelle-TalkTalk
Support Team
Message 8 of 11

Hi Pedant,

 

I'm sorry to hear this. We do have new firmware coming for the Sagemcom router which should resolve this particular issue. Would you like us to send the Huawei Wifi hub to see how the connection compares?

 

Thanks

 

0 Likes

paulshent
Community Star
Message 9 of 11

As mentioned on this thread there is no fix to the broken 2816t firmware DNS problems apart from a quick on  off of router / modem

May i suggest that they send you a DG8041W router that cures the problem. If they ask you say yes.  I use a DG8041W and it performs day in and day out without issue. If you d get this router it will be on firmware 1.05t  ask the OCE to upgrade it to level 1.06t. You will then have a stable router. Mine has been online for months without any issue.

 

Skynet_TX
Community Star
Message 10 of 11

Hi @Pedant,

 

This is indeed a known issue, new firmware that should address this problem is in testing at the moment, but it is not ready for release yet.

 

I've not heard of any way to 'fix' a router that is experiencing this issue, in the short term the current fix would be for the staff here to send you a replacement router.

 

The staff here won't be around now until Monday, but they should be able to respond to this post early next week to help.