FIbre Support

Get expert support with your Fibre connection.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

New customer - Trying to use own router + modem need help

First Timer
Message 7 of 7

Hello, can anyone help me please.  I'm a new customer this is first day since activation.   The supplied router works fine thank you however I want to use my own router + modem.  This same router + modem has worked fine with Vodafone fibre for the last 18months and now I'd like to use it on my new fibre 65 from TalkTalk.


I've read the "Set up a non-TalkTalk router" page which all makes sense but when I swap over to my own router + modem I can see the wan connection keeps going up and down as if it's failing authentication or something.


My router is a Juniper SRX-300 + modem is a Comtrend VR-3030.


If I spam checking the interfaces quickly I can see I do get an ip address but it will disappear again a few seconds later.   I've tried using new cables, and have tried a Huawei AR129CV with no success either. 


Any advice would be very appreciated as I'm a bit lost as to why it's constantly bouncing. 


Thank you in advance.




Message 1 of 7

No problem, good to hear you've got it up and working.  


Have a good weekend.

Message 2 of 7

Hello Birchcroft,  thanks again for your previous advice.


I've got it online now, the srx with either the comtrend modem or an old white echolife modem.  Your post made me think about the configuration I had done and where I'd made a mistake.


If it helps anyone else with this combination of kit, all I had to do was to factory reset the comtrend modem and configure the port on the srx which connects to the modem to be dhcp client. For some reason, despite reading the support page which didn't mention pppoe at all I still configured it - doh.  The old white echolife modem just worked too when I swapped it over, so the problem was deffo my misconfig of the srx.


Thanks again and hope you have a good weekend when you get there.





Message 3 of 7

@Captain7888 hope you get over the vaccine side effects soon.


I've had a quick look at the online manual for your modem.   It would appear the place to check/set what mode it is using is: Basic Setup - NAT Virtual Interface - User Interface.  This should be MPoA.  If not then that is what you need to set it to.  The VLAN insertion tag to use is 101.

Message 4 of 7

Thank you Birchcroft, that gives me something to look into, much appreciated.  Have been feeling bad since my covid jab so will look at that in the morning and do some packet capturing. Have a great weekend.


Message 5 of 7

@Captain7888 one thing to check is that the Modem is using MPoA rather than PPPoE/PPPoA 

Community Star
Message 6 of 7

Is this modem compatible with the TalkTalk network, it sounds like it may not be.

I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they?