FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No Change in Internet speeds after set up.

CoryRoss
First Timer
Message 5 of 5

I've just installed my fibre 65 router today however the speeds appear to be slower than promised. I've installed it on the master socket and even tested it with only 1 device connected. The router isn't near anything that would interfere with it. My minimum was 47 or 48 but I'm getting 40 Mbps. I also tested it on the admin section of the router settings.

 

It's a little frustrating as I'm paying for a 65mbps plan and was happy to accept the 47-55 range that I was quoted.

Cory Ross
0 Likes
4 REPLIES 4

Message 1 of 5

Hi CoryRoss

 

Thanks for updating your Community Profile.

 

I've checked the connection stats and your line is in sync at 40mb.

 

I'm just sending you a Private Message to confirm some details so I can check the speed range for your line.

 

Thanks

 

Debbie

0 Likes

Message 2 of 5

That's me added my number I had my account number there instead.

 

Cory Ross
0 Likes

Debbie-TalkTalk
Support Team
Message 3 of 5

Hi CoryRoss

 

Please can you add your TalkTalk landline number to your Community Profile. I can then take a look at this for you.

 

Thanks

 

Debbie

Skynet_TX
Community Star
Message 4 of 5

Hi @CoryRoss,

 

Have you just upgraded from Fibre 35 to Fibre 65, or is this a brand new Fibre 65 installation.

 

If you have upgraded from 35 to 65 then have you tried switching the router off for over 30 minutes to force it to create a new session when it is powered back on.

 

The TalkTalk staff on this community will be able to help, they will hopefully be able to respond to this post tomorrow.