FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No WIFI internet connection when changing LAN IP address

g0rsq
Team Player
Message 8 of 8

It looks like recently a problem has occured with my TalkTalk Wifi Hub.

 

I lost Internet connection when using WIFI (ethernet was OK).

 

After some diagnostics, I by chance have discovered if the LAN IP address is not in the 192.168.1.XXX range then the WIFI will not connect to the internet.

 

I had previously changed the LAN IP to 192.168.11.XXX range as this is the range I have been using at home for about 15 years (I have about 40 devices on my network).

 

I have resolved the issue by using another router to connect my home network to the TalkTalk IP range.

 

Why has this occured? It looks like the WIFI IP addresses are fixed and do not follow the LAN IP addresses set in the router which can be changed.

Peter Walker
0 Likes
7 REPLIES 7

Message 1 of 8

Hi Peter,

 

Glad to hear you've got it working. I can't see any action at our end at the time that you lost connection. Debbie just switched off wifi optimisation which shouldn't have caused the issues that you experienced and it was at a different time anyway


Chris

0 Likes

Message 2 of 8

In case it helps identify what happened, my cameras went off line at 13:15 on 30/12/2020, so maybe you can identify if that tied in with a particular action from TalkTalk

Peter Walker
0 Likes

Message 3 of 8

Well my network is commingback to life. Found out what IS wrong.

 

Test I made this morning.

 

1 Restet TalkTalk router to factory settings, and connected to my telephone line.

2 Waited for everything to connect on broadband.

3 Connected to the router with my phone over WIFI using default access.

4 Phone connected fine and gave internet connection over WIFI.

5 Went into TalkTalk router settings and changed IP from 192.168.1.1 to 192.168.100.1, and set DHCP server to 192.168.100.1 - 192.168.100.20. Saved and rebooted both router

and Phone

6 Connected my phone via WIFI using same default access.

7 Phone connected, but reported NO INTERNET.

8 Went into TalkTalk router settings (still using phone over WIFI) and checked everything was set. Phone connected on 192.168.100.2 as expected.

9 Connected laptop with ethernet (using DHCP) and reported connection 192.168.100.3, but NO INTERNET

10 accessed TalkTalk router settings from laptop, and no issues.

11 Checked ethernet properties of the Laptop and noted

 

IPV4 DNS SERVER was still on 192.168.1.1

 

Manually changed this to the correct setting 192.168.100.1 in the laptop network settings, and internet connection worked. Repeated on phone and internet was now available.

 

There is no setting in the TalkTalk router to affect this. Nothing else was connected to the TalkTalk router, just telephone, power, mobile phone via DHCP on WIFI and Laptop on ethernet by DHCP.

 

SO it looks like the DHCP server is not working correctly in the TalkTalk router, as it is not correctly forwarding the IPV4 DNS Server to the DHCP clients.

 

I have now replaced the TalkTalk router with my old SKY router, and everything is working exactly as it was before your firmware updates.

Peter Walker
0 Likes

Message 4 of 8

I do not know what you have done, but you have totaly destroyed my home network.

 

It is now impossible to connect to the internet via ANY WIFI device, unless the TalkTalk router is on 192.168.1.1 IP address.

 

I can connect to internet via any wired device over ethernet, but nothing via WIFI.

 

I connect to the WIFI hub, but always no connection to the internet, unless the WIFI hub is set to 192.168.1.1

 

I tried connecting behind another router, with its WAN set as 192.168.1.1, but no WIFI device will connect to the internet. They will connect to any device behind MY router but will not pass internet through YOUR router.

 

I have about 40 devices on my network, 15 with fixed IP addresses, so my network is now DEAD, this includes all my security system.

 

I am staggered that you can corrupt a private network in such a way with your Router.

 

I have now put an old SKY router in place of your router, and the system is starting to get up and running again, but I have to reconfigure all the WIFI cameras to use the new SSID's.

 

Hopefully I can use the same SSID on the new router without it causing issues with MAC addressing, as everything on DHCP has been assigned its own IP to make administering the system easier.

 

I have wasted about 6 hours on this this evening, its now 1:30 am, and I have had enough!

 

Tomorrow I will spen a few more hours sorting out the outdoor WIFI connections, and the WIFI Bridges.

 

As said the TalkTalk router is going in the bin. This was a fully functional network, with no issues untill you updated the firmware in the router.

 

I am dissapointed, as I have just returned to you from SKY, and now have a contract to see out. At least you cant mess with the router anymore.

Peter Walker
0 Likes

Message 5 of 8

Grrrrr

Just wrote a respons, when clicked POST button it told me I needed to login again, tried to do that and got error message OOOPPPSSSS.

 

I was already logged in, so another attempt to respond...

 

Thanks, I am now able to select the IP range I use for the rest of my network (192.168.100.xxx) and connect to internet via WIFI and Ethernet, so this is solved.

 

I also noted that my 2.4GHz WIFI channel had moved again and landed on top of another occupied channel (I turned 5GHz OFF because it was doing this, and planted its self on my Security cameras WIFI channel causing drop outs) so not too happy about this.

 

I have turned both 5GHz and 2.4GHz on, and moved then to the free channels I have, and will see if they stay there. If not then the TalkTalk router is going in the bin, as I can not rely on it to behave predictably.

 

This is my home security system that is being compromised by substandard software.

I dont think my insurance compant will be too happy to discover this!

 

Peter

Peter Walker
0 Likes

Debbie-TalkTalk
Support Team
Message 6 of 8

Hi g0rsq

 

I'm sorry to hear this.

 

I have switched off the WIFI optimisation, please can you retest and let us know how the connection compares.

 

Thanks

 

Debbie

0 Likes

KeithFrench
Community Star
Message 7 of 8

What make/model of hub are you using? There are two and their management is totally different?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they?