FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Persistent connection issues

pdwright1
Popular Poster
Message 16 of 16

Hi

 

Talktalk service started in April. Previously with Plusnet with flawless connection. 

 

Connection problems from the start which are intermittent but becoming increasingly frequent.

 

Consider myself to be relatively confident with networking and troubleshooting but cannot resolve these issues however I try.

 

Issue #1 is recurrent drop-outs

A device will remain connected to the router but will not have an internet connection. Won't say "no connection" will just keep trying to load a webpage, so maybe just has an impossibly slow connection. Only way to fix is to turn off wifi on said device and turn back on. Other devices unaffected at the same time. Has affected essentially every device connected to the router (phones, tablets, computers). 

 

Issue #2 is wildly fluctuant speeds

This may be the same issue as #1. Connection speeds to different devices, even when next to each other, wildly vary. iMac may have 20Mb/s speed with iPhone right beside it having 60Mb/s. iMac speeds randomly checked over 48h attached. Computer wasn't using the connection for anything else at any of these times. 

Screenshot 2021-07-22 at 15.12.31.png

 

I can only assume this is a problem with the wifi/router, as (1) I've never noticed it with an ethernet connected device and (2) all the diagnostics from Talktalk are saying my connection is stable and always providing appropriate speeds.

 

Any help appreciated 

0 Likes
15 REPLIES 15

Message 1 of 16

Hello,

 

Thanks for the update 🙂

 

Thanks

 

0 Likes

Message 2 of 16

Hello @Debbie-TalkTalk 

 

An update to say the Huawei hub resolved most of my issues.  I haven't noticed any drop-outs with this router.

 

The fluctuant speed issue did return, however.  This had been resolved when I used the old BT router as an access point.  I have now solved this issue (following online advice and some trial & error) by separating out the 2.4 & 5 GHz bands, and by preventing the router selecting the 80 MHz channel width for 5 GHz (so set to Auto 20/40 MHz).  Speed-sensitive devices are now connected to the 5 GHz SSID and this has entirely resolved the problem, though I'm not entirely sure why.  This may be useful for others.  

0 Likes

Message 3 of 16

Hi Phil

 

The Huawei hub is also a WIFI hub it's just a different make and model. I'm using the Huawei WIFI hub and it's been great.

 

The router is on its way, please allow 24-48hrs for this to arrive. Let us know how the connection compares with this router.

 

Thanks

 

Debbie

Message 4 of 16

Hello @Debbie-TalkTalk 

 

Yes, please could you send an alternate router. Is the Huawei model any less capable than what I currently have?

 

Now that you have the correct number, are you able to check for any line issues? More for reassurance as this issue doesn’t suggest a line issue. 

Out of frustration yesterday, I have now turned off the WiFi from the talktalk hub and set up my old BT Hub as an access point. So far (albeit not very long) this seems to have resolved the problem. This is the clearest evidence the router is the issue. 

0 Likes

Message 5 of 16

Hello @Skynet_TX 

 

Thanks for this. I had already tried this, changing to both talktalk and then google DNS, without improvement. I tried again yesterday following the exact steps you linked to, but still no improvement. 

0 Likes

Message 6 of 16

Hi Phil

 

Thanks for updating your Community Profile.

 

Would you like me to send a Huawei WIFI hub for testing to see how the connection compares?

 

Thanks

 

Debbie

0 Likes

Skynet_TX
Community Star
Message 7 of 16

So the pattern of behaviour you have is certainly not the most common that is caused by this known DNS issue, but if you wanted to try the workaround described below then that would help prove if the issue is in any way related....

 

At present your router will be acting as the DNS server for all of your devices, so when the DNS stops working in your router all of your devices will lose internet access. However you could configure your router so that it just tells all of your devices to use the TalkTalk DNS servers directly, therefore your devices won't use the router as a DNS server, and so shouldn’t be affected if the routers DNS stops working.

 

If you wanted to try this you just need to follow the instructions for the 'Wi-Fi Hub' here (ensure you go to the screen described in this article, as there are two screens in the router where you can modify DNS settings, but you must change the settings on the specific screen described in this article for this potential fix to work).

 

If you have never changed these settings before you will probably find that the primary DNS server is set to 192.168.1.1 (i.e. the router itself). You could change the settings as follows :

 

Primary : 79.79.79.79
Secondary : 79.79.79.80

 

These are the current preferred TalkTalk DNS servers (they are mentioned at the bottom of that webpage so you know they really are genuine TalkTalk DNS servers).

 

IMPORTANT : Having changed the settings you would need to make your devices disconnect and reconnect to the router (you could just reboot the devices or the router). When your devices have reconnected they will be configured to use those two addresses above as their DNS servers. So from that point on the devices will use the TalkTalk DNS servers directly rather than going via the routers DNS service.

 

Making this change may well resolve the issues for you, but if you do ever want to 'undo' this change all you need to do is put the old values back into that screen, or you could just factory reset the router by holding in the pinhole reset switch on the back for over 10 seconds, as that will return all settings back to their initial defaults.

Message 8 of 16

Hello @Skynet_TX 

 

Yes, would be very grateful for any potential workarounds. 

I do find the issue bizarre. A single device just seems to have no internet connection - but remains connected to the router and therefore doesn’t, say, switch to 4G - but can restore connection just by toggling WiFi off then on. Meanwhile every other device works fine. Have never had to restart router to clear issue (though have tried this a few times). 

I can only assume this is an issue with the router itself and it’s provision of WiFi. It can’t be a line issue or device specific issues. I am hopeful TalkTalk support may offer a replacement router when they are back next week. I have considered buying my own router but shouldn’t really have to. Ideally I’d go back to using the (supposedly inferior) BT router I was using flawlessly before, but it is locked to BT/Plusnet. 

 

0 Likes

Skynet_TX
Community Star
Message 9 of 16

The DNS bug does manifest itself in different ways for different people, the most common behaviour is that all devices lose internet access, but the LED remains white, and you need to reboot the router to get connectivity back. However some people have reported the problem only affecting certain devices at certain times. The fact that you get connectivity back by just disconnecting and reconnecting to wireless does make me wonder if you might have a different issue, as normally it needs a router reboot the clear the problem, but as I say, it does behave differently for different people, so it is still possible your issue does relate to this known bug.

 

If you are comfortable with logging into the router and changing some settings then I could give you details of something you could do that might work around the issue and stop it from causing this problem (even if you just wanted to try this temporarily just to see if it is the known DNS issue that is affecting you). If you would rather not do this then the staff here will be able to offer further help next week, they may be able to provide a replacement router of a different type for you.

0 Likes

Message 10 of 16

Hello @Ste_Nix14 

 

Thanks for your message. 

Ethernet connections appear stable and at expected speeds. 

The channel does seem to change back after I change it, presumably due to this optimisation. However it does stay on my selections long enough to find this certainly doesn’t eradicate the problem. 

If it is the DNS bug, would this affect all connected devices at the same time, or just an individual device whilst others still connect correctly?

 

Phil

0 Likes

Message 11 of 16

Hello @Debbie-TalkTalk 


Apologies for delay, have been away. The issue is still ongoing.  

 

The phone number was incorrect. I have now updated this. 

Phil

 

Message 12 of 16

Hi pdwright1

 

I'm sorry to hear this.

 

Can I just check, have you added the correct landline number to your Community Profile? (please do not post the number on this thread)

 

Thanks

 

Debbie

0 Likes

Message 13 of 16

Hi @pdwright1 

 

Issue #1

Sounds like it could be the notorious DNS bug where devices will continue to state they are connected and the Hub LED will be still white but act as if you have no Internet. This has been fixed in a newer firmware - still awaiting for this to be released in the not so distant future.

 

Issue #2

As @Skynet_TX said, it could be a Wireless  congestion issue. Please note this Hub will alter the channel if it sees fit even though you have turned of Automatic channel. You will need to Ask Support staff to turn 'Wireless optimization' off to stop this from happening.

 

What are speeds like when running a test on ethernet? Are they more stable.

 

Support staff may be able to swap hub put for a diffrent variation if your still facing issues after attempting the above troubleshooting.

Steve -
Have you tried turning it off and on again!
0 Likes

pdwright1
Popular Poster
Message 14 of 16

Hello

 

Yes, tried changing channels without improvement. 

I’m using Talktalk’s Sagemcom FAST 5364 running firmware SG4K10002816t. 

I would try an alternate router but the only ones I have are BT and Plusnet which won’t allow a Talktalk connection as far as I can tell.

0 Likes

Skynet_TX
Community Star
Message 15 of 16

Hi @pdwright1,

 

Have you tried changing wireless channels to see if you are suffering from Wi-Fi interference issues ?.

 

What make / model of router are you using ?.

0 Likes