FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Poor speed to device

slwukuk
Team Player
Message 87 of 87

I'm on Fibre 65 package.  The internet speed to router shows good but speed to device show as poor after speed tests. I was on live chat, they reset the router from their end and I cleared cache & cookies from my end, then the chat got terminated.  My wifi signal is poor no matter where I position my router and no matter how many devices are connected.

 

Any advice on how I can improve my wifi signal would be greatly appreciated.

0 Likes
86 REPLIES 86

ferguson
Community Star
Message 1 of 87

Aha, fair enough!  🙂

0 Likes

KeithFrench
Community Star
Message 2 of 87

Hi @ferguson just something for my own interest as I too need a new adapter.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

ferguson
Community Star
Message 3 of 87

@KeithFrench ????

0 Likes

slwukuk
Team Player
Message 4 of 87

I've PM'd you Keith, but yes they were screenshots from my new adapter.

0 Likes

KeithFrench
Community Star
Message 5 of 87

Hi @slwukuk 

 

Can I ask you a quick question, please? The screenshots from the Realtek utility you included yesterday, were they from this new card or the original one? So many use the Realtek chipsets it can be difficult to know. To be certain please could you get me the output from the Windows command prompt by using this command:-

 

netsh wlan show interface

 

Then press the Enter key. Please can you paste the output or get a screenshot of it for me? Please feel free to PM it to me if you prefer.

 

Thanks.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

KeithFrench
Community Star
Message 6 of 87

You're very welcome.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 7 of 87

The speed I get to my router is really good, I have no complaints with TalkTalk at all.  People are too quick to slate anything that isn't going their way, when usually the problem is easily fixed when you know what you are doing, which I am thankful for this community for pointing me in the right direction.  I understand stuff better at the end of this thread than I did when I first started it.  Thanks again people 🐵 🐵 🐵

0 Likes

ferguson
Community Star
Message 8 of 87

Hey @slwukuk keep at it! Different solutions work for different devices. At least we have established that your TalkTalk service is fundamentally sound and you have found a way to improve the wireless speed to your laptop. 

0 Likes

slwukuk
Team Player
Message 9 of 87

That's right, I always did use it wired, up until one of the Powerline adapters failed, but I've read that Powerline adapters don't last forever.  

0 Likes

KeithFrench
Community Star
Message 10 of 87

Ethernet will always deliver the best performance for TVs & other audio-video equipment.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

slwukuk
Team Player
Message 11 of 87

The TV does actually connect to the internet, it's just connected via wifi, the signal strength mustn't be strong enough as it won't even run any youtube videos.  I'm just goona buy some more Powerline adapters eventually.  Thanks for all the help given 🐵

0 Likes

KeithFrench
Community Star
Message 12 of 87

Hi @slwukuk 

 

@ferguson has said what I was about to, just use it in station mode for the laptop. Then deal with the TV's internet access as a separate issue, connecting that to the hub.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

slwukuk
Team Player
Message 13 of 87

Yeah I've left it that way Ferguson, see I thought that it should be the newly created access point that I should be connecting to, to give me the increased speed.  That's what I thought an access point would be.  Anyway, Netflix can actually run via my firestick, but the Netflix app on my TV tends to get stuck when trying to view any film or series, I know if must be a wifi issue because when I used to connect via my my Powerline adapters the Netflix app would work fine.  One in the pair of Powerline adapters has broken so I'm definitely gonna buy another set.  But as for my new wifi usb adapter, it has more than doubled the wifi speed to my laptop 🐵 🐵 🐵

0 Likes

ferguson
Community Star
Message 14 of 87

Leave the adapter in station mode. That will allow you to connect your laptop to the Hub at the best speed.  Your TV should be connected directly to the Hub, not to the adapter. as access point. 

0 Likes

slwukuk
Team Player
Message 15 of 87

Yeah mate I understand how it works, that's why it has me baffled.  The TV connects to the access point, and it's the TV that is showing me that there is no internet.  I can even test internet strength on the TV, but no internet when connect to the access point.

0 Likes

KeithFrench
Community Star
Message 16 of 87

I have never used this facility, but I would imagine it should work like this.

 

When you are in Access Point mode, I don't think that the laptop will be connected to the internet itself, only the WiFi adapter is, as it is behaving like your router. It is broadcasting out a new network for your TV etc to connect to.

 

When in Station mode, the adapter is acting as an ordinary WiFi client & it connects to the router's WiFi to give the laptop internet access.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

slwukuk
Team Player
Message 17 of 87

Kind of all sorted now Keith, via the new adapter I'm getting download speed of 60.5mbps which is great (for my laptop).  I am having a bit of chew when I put the adapter to 'access point' as I want to connect my smart TV.  I disable my onboard network card, and no internet, but it only says no internet when set as access point. I can disable my onboard network card when in 'station mode' and I get an internet connection.

0 Likes

KeithFrench
Community Star
Message 18 of 87

Hi @slwukuk 

 

How are you getting on now?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

KeithFrench
Community Star
Message 19 of 87

Of course by splitting the SSiDs you are on the 5GHz band. However, that has half the range of the 2.4GHz band. It can be better to keep the network name identical ,& let the network adapter decide which is best. Then to find out which band you are connected to, just go to the command prompt and issue this command and press Enter afterwards:-

 

netsh wlan show interface

 

Then paste the output here or PM it to me & I will check it tomorrow afternoon.

 

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

KeithFrench
Community Star
Message 20 of 87

Hi @slwukuk 

 

I'll read through all of this & get back to you tomorrow afternoon.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes