FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problems with F@st 5364 Router

ArthurW1
Popular Poster
Message 13 of 13

My router stops working regularly - its white light stays on but there is no internet - either wifi or through ethernet cable. Turning it off and on again sorts it until the next time.

I am using a F@st 5364 router and Fibre 65.  It has been reset several times but this doesn't help.

I have now been told that I have too many devices connected.  I can count 15-20 - they don't use the Talk Talk wifi as I have a separate wifi system. I have read that the router is good for a small number of devices but also that it can cope with 50 devices.

Can anyone help me?

Is there a more suitable Talk talk router - is the Super Router better or worse?

Thanks

ArthurW1

0 Likes
12 REPLIES 12

Message 1 of 13

Hi Arthur,

 

glad our team was able to help.

 

Regards,

 

Karl. 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

0 Likes

Message 2 of 13

Hi Debbie

Just to let you know that the new router is doing well - so I will return old one

Thanks again for your help - much better than all the times i phoned in for support

Best wishes

Arthur

0 Likes

Message 3 of 13

Hi Arthur

 

That's great news, thanks for letting us know 🙂

 

Debbie

0 Likes

Message 4 of 13

Thanks Debbie

 

The new router arrived and is working well so far.  Assuming it keeps working,  OK, I'll send back the old one.  

Thanks again for your help.

ArthurW1

Message 5 of 13

Hi Arthur

 

No problem 🙂

 

Please let us know how you get on.

 

Thanks

 

Debbie

0 Likes

Message 6 of 13
Thanks Debbie

Much appreciated.

If the new router doesn't solve the problem I will contact you again through this Chat.

ArthurW1

Message 7 of 13

Hi Arthur

 

Yes that makes sense 🙂

 

I'm using the Huawei hub at the moment and I think it's a really good router.

 

I have ordered you a Huawei hub for testing and you should receive this within the next 24-48hrs.

 

We would need you to send the Sagemcom hub back using the pre paid returns bag (I've ordered)

 

At a later date, if you would prefer to use the Sagemcom hub again then I can send this out again and hopefully the firmware will then be available.

 

Thanks

 

Debbie

0 Likes

Message 8 of 13

Hi Debbie

 

Does that have the ability to cope with the traffic of my devices?  If so, maybe I should try it and then,  if it doesn't prove able to cope, revert to the present F@st 5364 Router once there is a Firmware update.

 

Does that make sense to you?

 

Arthur W1

Message 9 of 13

Hi ArthurW1

 

Thanks for updating your Community Profile.

 

We do have new firmware coming soon for the Sagemcom router but I don't have a specific date that I can share as yet.

 

Would you like me to send you a Huawei WIFI hub?

 

Thanks

 

Debbie

0 Likes

Message 10 of 13

Thanks Debbie

I have updated my profile

 

It sounds as if i should hang-on for the firmware update unless there is a more suitable router available.

 

ArthurW1

Debbie-TalkTalk
Support Team
Message 11 of 13

Hi ArthurW1

 

Can you please update your community profile to include your:

  • Name
  • Telephone number
  • Alternative contact number

We'll then look into this further. Please do not post this information on this thread. Once you've updated your profile please post in your topic to confirm it's updated. 

 

Thanks

 

Debbie

0 Likes

Skynet_TX
Community Star
Message 12 of 13

Hi @ArthurW1,

 

There is a known DNS related issue with this router that can cause symptoms very much like the ones you are seeing, so it maybe that you are suffering from that issue. There is a new version of firmware being tested at the moment that will hopefully resolve this, but it is not quite ready for release yet.

 

For one of the TalkTalk staff on this community to be able to look into this you will need to update your community profile to include your name, landline telephone number that your TalkTalk service is provided on & an alternative contact number. This will allow them to identify you, and they will then be able to help.

 

Don't post any personal details in this thread, just add them to your community profile.

 

Then they will hopefully be able to respond to this post tomorrow.