FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Really bad support from Talk Talk

sayl100
Repeat Guest
Message 16 of 16

I've been a customer of TT for about 4/5 years, my package is the Fiber Gfast and always had really good speed.

 

My setup has been untouched now for a number of years, yesterday morning I could not connect to the work VPN, after running various tests at my end I decided to call/chat with TT support.

 

Test run on my line:

Connect to the vpn using same laptop no connection

Connect to the vpn using a brand new laptop no connection

Connect to the vpn using Mobile phone 4G connects absolutely fine

No update to the VPN infrastructure for the past 6 months, I'm the tech person who has set up the infrastructure.
All colleagues can connect absolutely fine to the VPN

I have reset the router to factory settings, same issue

If I replace the TT router with an old one issue is fixed

All of the above during 3 hours of chatting to various agents since for some reason they ended chats abruptly, finally after 3 hours they agreed to escalate to next level and to expect a phone call on the same day, needless to say, no one called me back, this morning again on chat support, agents asking me to explain again the issue when they could have read the case notes, when I asked why no one called me back the answer was for me to contact the VPN provider after I explained several times I'm the VPN provider, when I pressed remarking the fact that replacing the router with an old one solves the issue I was told that they could put me in contact with the sales department to purchase another router of the same model with same updates... at this point it felt like they were pulling my legs, when I asked again for the case to be escalated the answer was to contact the VPN provider or to purchase another router from Talk Talk.

Agents are clearly not interested in solving the issue or the company has told them to deny the evidence, this is one of the worst support I've ever received.

PS: TT usually pushes updates to the router without customer knowledge.

 

 

15 REPLIES 15

Message 1 of 16

Hi

 

Just following up on the recent VPN Issue you had, to aid our Teams in their investigation of the issue affecting the Sagemcom 5364 router running Firmware V130t.

 

Can you let me know if you tried changing the Firewall level in the router and if this allowed the VPN to connect.

 

Also, when using Windows inbuilt VPN, can you let me know what setting you chose from the below image.

 

 

Thanks  

 

Karl. ​​​​​​​

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

0 Likes

Message 2 of 16

No Problem 🙂

 

Karl 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

0 Likes

Message 3 of 16

Thank You Karl,

 

I've received the new router and has been running since yesterday, it now works with the VPN although sometimes it stops allowing me to surf the net.

 

I will keep running the vpn and advise if the issue requires further attention.

 

Kind regards and thank you again for your help.

0 Likes

Message 4 of 16

Hi

 

Just checked with the courier, this is out for delivery today.  There are 12 stops for the driver before you.

 

Thanks  

 

Karl. 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

0 Likes

Message 5 of 16

Good Morning Karl,

 

Any news about the replacement router? 

 

Thanks.

0 Likes

Message 6 of 16

You're Welcome 🙂

 

Regards 

Karl 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

Message 7 of 16

Thank you Karl!

Message 8 of 16

Hi

 

I'll get a different model hub out to you whilst we are looking into this.

 

Thanks  

 

Karl. 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

sayl100
Repeat Guest
Message 9 of 16

I'm using Microsoft PPTP protocol.

I've posted this answer about 10 times but looks like it gets deleted after few hours.

0 Likes

Message 10 of 16

Hi,

 

Thanks for confirming. I've raised this to our Products Team now. Which VPN client are you using?

 

Thanks

 

0 Likes

Message 11 of 16

Hello,

 

I've factory-reset the TT router this morning, about 3 hours ago and the issue is still there, if I connect the old router VPN is connecting within a split second. 

0 Likes

bigkenny
Problem Solver
Message 12 of 16

I think with you saying `VPN` that’s their (TT) get out of jail card, you would have been better off not saying you have a VPN. It best to give them less ammo so to deflect your problem. just say router broke and you have tested with an old back up one and works with that (or words to that effect) and leave it like that don’t give them a reason to think it’s your problem on your side.

Message 13 of 16

Hi,

 

Thank you. I've checked and the router has recently updated to our new version of firmware. Could you try factory resetting the TalkTalk router only, then re-set the router back up and then retest the VPN again please and let us know how you get on.

 

Thanks

 

0 Likes

Message 14 of 16

Done, I've updated my profile with the requested details.

0 Likes

Michelle-TalkTalk
Support Team
Message 15 of 16

Hello,


 

Can you please update your community profile to include your:


  • Name

  • Telephone number

  • Alternative contact number


  •  

We'll then look into this further. Please do not post this information on this thread. Once you've updated your profile please post in your topic to confirm it's updated.


 

Thanks

 

0 Likes