FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Remote Desktop doesn't work within own network

cmthomp
Team Player
Message 10 of 10

So, new to Talk Talk as of today.  Previously with Sky with no issues.  I have a server on my home network running Win10 which I connect to using RDP from whichever device I want to within my home network.  This has stopped working.  No settings have been changed on the server or any of the PC's & Laptops that want to connect to it.  It just doesn't connect.  How do I fix this? The UX on the new router is terrible by the way!

0 Likes
9 REPLIES 9

Message 1 of 10

Hi cmthomp

 

Thanks for letting us know.

 

Debbie

0 Likes

Message 2 of 10

Solved this myself.  Nothing to do with loopback as was within my own network.  Despite no IP addresses changing, I ran the network troubleshooter on the server which reset something that then pinged the RDP back into life.

Message 3 of 10

Hi cmthomp,

 

When you access the device on your network from you network, are you access it via the Internet? If you are then the issue you're experiencing is probably due to loop back restriction

 

Chris

Message 4 of 10

Yes, still have the issue.  Have also tried opening the RDP port in the router but no difference, still doesn't work.

0 Likes

Michelle-TalkTalk
Support Team
Message 5 of 10

Hi cmthomp,

 

I'm sorry for the delay. I've checked and I can see that the router now has the latest version of firmware. Are you still experiencing this issue at the moment?

 

Thanks

 

0 Likes

Message 6 of 10

Yep, I'd already read a little bit about that, even though it's off it makes no difference.  Internally the only thing I should need to enable is UPnP which is also on.  I note that I have very old firmware, so might need to upgrade that too as I would like to reserve some IP's and can't do that either!  Not a great start!

0 Likes

fr8ys
Community Star
Message 7 of 10

This turns off scam protection which also stops remote viewers working.

 

 

Please remember to mark Solved Posts with Best Answer. Doing so helps other customers and saves TalkTalk's Support Team time by only looking at unsolved topics. Thanks, Steve (a fellow customer).
0 Likes

Message 8 of 10

Thanks for trying but it's not Homesafe.  Just checked everything in Homesafe was already off, I declined the offer of it when I signed up.

0 Likes

fr8ys
Community Star
Message 9 of 10

Hi,
If you go to my account, you can turn this off there.
To do so:
1 Log in to MyAccount
2 Select My Services
3 Select View HomeSafe settings
4 Select OFF and confirm when you see the pop-up window

You may also need to disable any pop up blocker you may have installed

Good luck.

Please remember to mark Solved Posts with Best Answer. Doing so helps other customers and saves TalkTalk's Support Team time by only looking at unsolved topics. Thanks, Steve (a fellow customer).