FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Router Not Working - Last Ditch Attempt

annlivi
First Timer
Message 12 of 12

This is my last ditch attempt to try and get full use of the service in which I'm paying for seeing as speaking over the phone or using the online chat does not work. The customer service has been absolutely shocking and I'm someone who never complains. I can honestly say I will not be recommending talk talk and if the issue isn't resolved would rather pay extra cash to end my contract and pay another provider for a service I have full use of and proper customer service.

 

The issue being I have a Sagemcom router which I use to connect to my works VPN. This was working perfectly fine from March 2020 until near the end of 2021 where one day the router stopped allowing me to access my works VPN. My works IT department done various checks and identified the problem was with the router. 

 

I spoke to someone on the phone regards this last year and it resolved nothing. Still have the same issue. I then spoke to someone in January where I ended up signing up for fibre broadband. I hoped the new fibre broadband would help resolve issues as assumed I would get a new router. .......it has not. Instead I have the same router that doesn't allow me access to the VPN along with an additional BT Openreach modem.

 

I then spoke online with someone and was told a router would be sent out within 14days. After no contact for a month I spoke to someone online again to be told it had not been sent out after promising it would be! The next person I spoke to then refused to send a router and said they would get a manager to call me within 48 hrs. That was back on the 24th of February and have heard absolutely nothing!

 

I know the issue is with the router as when I connect the computer via ethernet directly to the modem cutting out the use of the router I can connect to the VPN no problem. However as the modem has no wifi and only one port it means no one else has use of the internet when I do this.

 

I have also tried borrowing my neighbours router and connected it to the modem and again the VPN worked perfectly fine via the wifi. However I can't keep the neighbours router.

 

I have followed the online instruction and also done a factory reset which does nothing.

 

Appreciate if you could please finally help me resolve this. I have never experienced such disgusting customer service in my life.

 

I've seen plenty of posts on here from people with the same issue who received routers straight away and resolved their issues. So why after 3 phone calls and two online chats are you refusing to help??

0 Likes
11 REPLIES 11

Message 1 of 12

Morning,

 

I'm really glad to hear this and I will pass your feedback on to Debbie 🙂

 

Thanks

 

0 Likes

Message 2 of 12

OMG. I cant believe it! After more than 6 months its finally working! 

 

As soon as I restarted the router it let me connect to the VPN straight away. Thank you so much.

 

Can I ask why after all the phone calls and live chats no one done this to start? Literally no one logged into my router to try this.

 

I just wish everyone else was as competent as you. Thanks again for your help.

 

Lesson learned if I ever have issues again to use the forum instead.

 

Thank you!

Message 3 of 12
0 Likes

annlivi
First Timer
Message 4 of 12

That’s great, thank you Debbie.

 

Will be the first thing I try! Keeping my fingers crossed.

Message 5 of 12

Hi annlivi

 

No problem 🙂

 

The firmware has now been updated. Please can you retest this evening when you get home and let us know how you get on.

 

Thanks

 

Debbie

annlivi
First Timer
Message 6 of 12

Ah okay. Yes please. Thank you Debbie

Message 7 of 12

Hi annlivi

 

You don't need to be at home for me to do this firmware update. I can start this now, if that's ok?

0 Likes

annlivi
First Timer
Message 8 of 12

Hi Debbie,

 

That would be great thanks. Due to the issues i am in work and wouldn’t be able to make it back until 5pm today. Is this too late? If so I can try to get away and be back at lunch time.

 

thank You 

0 Likes

Message 9 of 12

Hi annlivi

 

I'm so sorry to hear this.

 

I will need to try a different firmware version, when would be the best time to arrange this?

 

We advise to leave the router switched on without being rebooted whilst we update the FW, this should take no longer than 15 minutes to update.   

 

Thanks

0 Likes

Message 10 of 12

Thank you Ferguson. I hope so as I have shed a few tears over this because of the work issues it is causing. So frustrating when you see people get it resolved in a matter of days yet more than 6 months later and I'm still waiting. Fingers crossed and thanks for the response.

ferguson
Community Star
Message 11 of 12

Sorry to read about your problems getting this sorted so far, but I think you have come to the right place! The support team here will respond as soon as they can when they are back online tomorrow.