FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Sagemcom - SG4K100130 - DNS Issues

UFO_User
First Timer
Message 11 of 11

 

I used to have custom DNS servers set on my Sagemcom router, a 192.168.1.xxx address. I noticed internet issues today and tried to log into my router to check.

 

The admin password no longer worked. "Wrong login information" error.

 

Held in the reset button the back for 30 seconds and I was able to log back in using the same password I'd been trying.

 

Having reset all my reservation settings, I went to set my DNS servers again, changing the DNS IPv4 from  "Obtain DNS Automatically" back to my internal address doesn't work, it results in no internet activity as DNS requests fail.

 

I did notice updating the DNS settings automatically adds a route on the other screen. This route looks incorrect though, it's trying to send internal traffic out to the internet and I can't update or remove this route - it's auto generated based on the DNS servers I enter. The DNS servers are internal though.

 

-----

Also trying to change the admin password, I get the following error no matter how simple a password I tried to enter.

 

Valid characters for the password are uppercase and lowercase letters and numbers

-----

 

Any chance I could go back to the older firmware please. Everything was fine on that until two days ago.

 

Thanks

 

FAST5364 3.00

SG4K100130

 

0 Likes
10 REPLIES 10

KeithFrench
Community Star
Message 1 of 11

That is exactly how it is supposed to work.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 2 of 11

Okay thanks @KeithFrench , I've actually managed to get it sorted via how you've suggested.

 

I'm pushing out my internal DNS server via DHCP using the Static DNS Server Configuration option.

 

And leaving the Google DNS servers configured on the router in DNS WAN IPv4.

 

Slightly different to before, previously all DNS requests to my internal server were from the router itself 192.168.1.1 but now the clients are communicating directly with the DNS server.

Message 3 of 11

Dashboard > See Wi-Fi Settings > Manage Advanced Settings > TalkTalk Wi-Fi hub > DNS

 

Static DNS Server Configuration

That's left as blank so defaults back to the router which is fine. 192.168.1.1

 

 

Dashboard > See internet settings > Manage advanced settings > Internet connectivity

DNS WAN IPv4

Manually Specified. Currently Google, changing these both to my internal address, browsing stops.

 

 

Whatever IP I add as the DNS servers get these routes added automatically with the 92.21.48.1 gateway.

 

This was all functioning fine up until 1:30am on the 8th I think it was.

 

Cheers

0 Likes

Message 4 of 11

Where are you changing the DNS, Google DNS should go in:-

 

Dashboard > See internet settings > Manage advanced settings > Internet connectivity

 

The local DNS server needs to go in:-

 

Dashboard > See Wi-Fi Settings > Manage Advanced Settings > TalkTalk Wi-Fi hub > DNS

 

That way it will be handed out in DHCP offers. In fact, I think there is a block in using public IP addresses here.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 5 of 11

Thank you @KeithFrench that explains the password issue, that may have been the case for a while. As this was the first time I've been locked out I naturally went to change the default password when I logged in.

 

 

Anyone else reported DNS issues with changing the DNS servers to internal addresses and it stopping browsing working? I may be going down the wrong path with the routes table, but having made the same changes as I did on the previous firmware version and it not working I went looking around more of the config options and noticed the pre-defined route based on the IP address for the DNS server I entered that I can't modify or delete.

 

Changing to Google DNS 8.8.8.8 8.8.4.4, everything still works, changing to 192.168.1.23 for example and browsing stops, DNS failures.

 

Thanks

0 Likes

KeithFrench
Community Star
Message 6 of 11

This was actually introduced in V0124 that preceded V0130.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

ferguson
Community Star
Message 7 of 11

Marvellous.  🙄

0 Likes

KeithFrench
Community Star
Message 8 of 11

No @ferguson , it was me that found it out & drew it to the attention of TalkTalk.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

ferguson
Community Star
Message 9 of 11

Nice one @KeithFrench, is that information otherwise made clear to users by TalkTalk?

0 Likes

KeithFrench
Community Star
Message 10 of 11

The admin password security policy has been tightened up in this release. You must have at least one uppercase, 1 lowercase & 1 numeric digit within the password, I think that the minimum length is still 8 characters. If you do a factory reset on the router, that is the only way to get it back to the password that shipped with your router, you cannot manually change the password back to what it was originally as there are no lower case characters in it.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they?