FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Slow device speed

j_o_elliott
First Timer
Message 6 of 6

I have recently upgraded to fibre 65 and although I am getting good speeds to my router 47mbps it appears that my device speed is still limited to 37mbps. Is there anything I can do to fix this?

Currently I am connected to a Deco s4 mesh Wi-Fi network 

0 Likes
5 REPLIES 5

Message 1 of 6

Hi j_o_elliott

 

That's great, thanks for letting us know 🙂

 

Debbie

0 Likes

j_o_elliott
First Timer
Message 2 of 6

Thanks all, powering down the router for 30 minutes seems to have fixed the problem.

martswain
Philosopher
Message 3 of 6

@j_o_elliott if you have close neighbours, then WiFi interference from them can slow down your own connection.

 

Suggest you download a WiFi analyser to "see" your local environment and then change your router channels on each band to the least congested channels.

 

If you have the Sagemcom HUB then it is best if the WiFi Optimisation feature is disabled as that can change channels automatically and not always select the best, just post here and ask a staff member to do it remotely as it is not a user selectable option.

0 Likes

Debbie-TalkTalk
Support Team
Message 4 of 6

Hi j_o_elliott

 

Have you powered down the router for a full 30 minutes and then run a speed test?

 

Thanks

 

Debbie

0 Likes

Skynet_TX
Community Star
Message 5 of 6

Hi @j_o_elliott,

 

Have you tried switching the router off for over 30 minutes since you upgraded, if not then that would be worth a try. This will get you a new session in the street cabinet, and can often resolve this type of issue.

 

The TalkTalk staff on this community will also be able to help, they will hopefully be able to respond to this post tomorrow.