FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Slow speeds despite having Fibre 65

NKP1990
First Timer
Message 7 of 7

Hello,

 

I've been getting internet speeds of 11 Mbps over the past 2 days now which is substantially slower than the 'minimum guaranteed speed' of 43Mbps on my Fibre 65 contract and I don't know why this is happening. It started on Saturday evening when I noticed that the Internet was slow after trying to browse a restaurant website to book a table. I thought nothing of it because I thought it would fix itself as it always does. Until I woke up the next morning and did a random speed test and found that the Internet speed was still 11 Mbps. I ran independent speed tests on multiple devices seperately and even using the ethernet cable to my laptop and I got the same speed. I shut off all devices and checked the speed with just one device, my phone, and still the speed was the same.

 

I called customer service and they ran a bunch of tests which included: speed tests, Line tests, Resetting the router, changing WiFi channels etc etc, but to no avail. They claim there isn't an issue on their side. I even checked the router settings via the admin login at 192.168.1.1 and the information on there points to Fibre speeds. So I'm at a loss. I've asked them to arrange for an engineer visit.

 

But, what I find weird is that it's just the download speed that seems to be 'restricted' to specifically 11 Mbps. It never fluctuates higher or lower than that. The upload speed seems to be in line with the Fibre 65 description at 18-20 Mbps. Could some one please advise or help me figure out what could be causing this?

0 Likes
6 REPLIES 6

Message 1 of 7

Morning,

 

Ah no problem 🙂 I'm glad to hear that the speed has improved.

 

Thanks

 

Message 2 of 7

Thank you for your advice. It worked!

NKP1990
First Timer
Message 3 of 7

Hello, 

Thank you @Michelle-TalkTalk for checking up on me. Apologies for the late update. I dozed off last night after my previous reply. I can confirm and am delighted to say that my Internet seems to be back to normal again! I switched off the router, as advised by @Skynet_TX , for more than 30 mins and it seems to have dine the trick. I did a speed check on two separate devices and they both registered speeds in line with my Fibre 65 package. I will run another speed test later after work and monitor the speeds over the next few days just in case. But thank you very very much @Skynet_TX for your help!

Message 4 of 7

Hello,

 

How are you getting on? Do you still need assistance with this?

 

Thanks 🙂

 

0 Likes

NKP1990
First Timer
Message 5 of 7

Hi @Skynet_TX. Thank you very much for your advice! I appreciate it. I will definitely try that. Fingers crossed!

Skynet_TX
Community Star
Message 6 of 7

Hi @NKP1990,

 

If the download sync speed reported in your router (when you log into 192.168.1.1) is normal, but your speed test results are significantly slower, have you tried switching your router off for over 30 minutes, this will force a new session in the street cabinet and can often resolve issues like this where the throughput speed is much slower than the sync speed.

 

If that doesn't help, then for one of the TalkTalk staff on this community to be able to look into this you will need to update your community profile to include your name, landline telephone number that your TalkTalk service is provided on & an alternative contact number. This will allow them to identify you, and they will then be able to help.

 

Don't post any personal details in this thread, just add them to your community profile.

 

Then they will hopefully be able to respond to this post tomorrow.