FIbre Support

Get expert support with your Fibre connection.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

TalkTalk Router Bridge/Model mode

First Timer
Message 2 of 2

Hi all,


Here's advice if you are trying to get your TalkTalk Router* in Bridged/Modem mode so you can use your own third party device:


You can't.


Having spent an hour on hold with a technical engineer who was asking everyone under the sun how to do this, I was finally told that it isn't possible with their devices.


Hopefully this will help the next foolish mortal before they go down the same road.


*(TalkTalk Router model is: Huawei DG8041W)


Community Star
Message 1 of 2

Yes, you can use it, but how do you do it depends on what router you have bought, its capabilities & how you want to use it & connect it to the TalkTalk router.


Bridge mode is of no use to you, that disables all routing functions and you would never be able to route IP packets from the local private IP network to the public one on the WAN side of the router. Whilst no current TalkTalk router supports modem mode, you can still use it as the initial router connected to your broadband. You can also disable its WiFi if you want.


My general recommendations are to disable any DHCP server on the 3rd party router & put it into bridge mode, this is the simplest way.


Then, if your 3rd party router has a WAN Ethernet port, you can connect from the TT LAN port to that WAN port, this time leave the DHCP server enabled on the 3rd party one. This introduces a complexity of double NAT which is fairly easy to get around if you know what you are doing. It is of no worry whatsoever though, if you are not using port forwarding.


I regularly use another router connected in this manner from my DG8041W, with double NAT in full use.


Of course, the easiest way of all is to have bought a 3rd party router with an inbuilt modem suitable for your type of fibre/ADSL that supports connection to the TalkTalk router.

I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they?