FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to access any site starting 'talktalk'

JeffQWard
First Timer
Message 3 of 3

For the last two weeks I have been unable to access any site that starts with 'talktalk'. This includes my email and account. I have reported this and asked for help but apart from getting a quick acknowledgement , I have heard nothing. 

When trying to log on to a talktalk site, I get a message that says  - page not accessible and connection reset.

My main pc is on Windows 10 and Google Chrome.

I have tried connecting with my android phone, i-pad and another pc running linux OS and Firefox but get the same result.

I can log on to my email using another pc on a different network.

The only thing that is common to all my devices is the router.

I have tried a factory reset but still the same result.

Anybody got any ideas?

 

 

Jeff
0 Likes
2 REPLIES 2

Michelle-TalkTalk
Support Team
Message 1 of 3

Hi Jeff,

 

I'm sorry for the delay. How are you getting on?

 

Thanks

 

0 Likes

paulshent
Community Star
Message 2 of 3

Few things to try.  1) Have you taken all updates to Windows 10 ?  2) What release of Windows 10. You can get this from system menu. 3) Have you flushed the cache for the Google  browser.  4) Download a free copy of Firefox and see if that does the same.If it works then the issue is with Google Chrome browser. 5) is it only talktalk site you have issue with. Lastly have you done a power reset on your router, if not try that first.

Have you tried Microsoft Edge on Windows 10, since that is based on Google Chrome.? 

 

0 Likes