FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to change DNS settings

Leicesterchris
Popular Poster
Message 6 of 6

Hi, im using a TalkTalk Wi-Fi Hub - software version SG4K10002816t.

I want to change my DNS server however when I navigate to the DNS tab to the static DNS server configuration the "enable" box is stuck on "on" and the primary and secondary DNS servers cannot be edited.

I have tried a soft and hard reset but the DNS servers still cannot be edited.

Is this due to a recent software update or something?

0 Likes
5 REPLIES 5

Message 1 of 6

No, they won't change there.

 

The way that DNS works, is that the router connects to DNS hierarchic tree. It then behaves as a DNS cache & hands out the router's IP address as their DNS server to each of your devices, via the DHCP address IP allocation process.

 

This really needs to be on the same subnet as the router, even if you are using your own DNS server.

 

You do not hand out the network DNS server (e.g. Google DNS) to your devices unless you want an inefficient DNS system.

 

The router learns the majority of sites you visit and stores the IP address/domain pair in its DNS Cache, only querying the network DNS servers for a domain it does not recognise. The router is much closer to the devices than Google's DNS server. So if the devices had to query Google each time, that makes for an inefficient DNS service.

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

Message 2 of 6

Thanks Keith

 

That did let me update my DNS servers - however on the DNS settings tab in the TalkTalk wifi hub (under advanced settings) this still has my original DNS servers.

 

I presume your fix will actually set my DNS servers - but it does seem odd to have two tabs for DNS servers (even though one doesn't work!). I suspect this was from a recent firmware update as this hasn't been updated on the "Using a 3rd Party DNS" help page from TalkTalk - https://community.talktalk.co.uk/t5/Articles/Using-3rd-Party-DNS/ta-p/2205279

0 Likes

Message 3 of 6

Sorry, try going to:-

 

Dashboard > See internet settings > Manage advanced settings > Internet connectivity

 

The DNS tab you mention is where the DNS servers handed out by DHCP to your clients can be changed. This is not the place to make the change you want.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 4 of 6

Hi Keith

 

I cant see the "internet connectivity" tab in the advanced settings of the wifi hub. 

 

Ive attached a picture of the tabs I can see.

 

If I select the "DNS" tab it does bring up the primary and secondary DNS servers but the IP address boxes are greyed out and cannot be changed despite the "Enabled" switch being on. If I click the "Enabled" switch it doesn't respond.

0 Likes

KeithFrench
Community Star
Message 5 of 6

Go to:-

 

Dashboard > See internet settings > Manage advanced settings > TalkTalk Wi-Fi hub > Internet connectivity

 

To use different DNS servers (Google DNS in this example), change the DNS dropdown box to Manually Specify DNS. Then set DNS 1 & DNS 2 as shown:-

 

Change DNS Server.png

 




Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes