FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unstable LAN since rejoining TalkTalk

Mr-Burns
First Timer
Message 4 of 4

Hi there,

 

I was previously a TalkTalk customer in 2018-2020, and had a nice stable network setup during that time - a mix of wired and wireless devices all sitting on a 10.x subnet, pi-VPN server with a static route set in router for LAN access when I connecting via that, the usual sort of firewall rules, and Fibre 65 running of a sagecom wifi hub.

 

After that I moved to Vodafone for a better 18 month deal, and again everything played nicely.

 

In Nov I switched back to TalkTalk as Vodafone were only offering deals to new customers, and I (thought) I knew that everything worked well with the talktalk router so no concerns there...

 

Fast forward a couple of months since plugging in the newly posted sagecom wifi hub (newer hardware revision and newer firmware than the last one) and i've had nothing but annoying unstable issues with the internal connections. 

 

It started on day 1 with changing off the 192.168.1.x  subnet, and there is some sort of GUI bug that won't let you specify a different DHCP range - found a forum post with instructions to do a browser console tweak wiht $.xmo.setValuesTree to work around - seemed to work.  I still can't seem to get my firewall rule and static route to work properly for the VPN though.

 

What is worse however is that I am regularly getting disconnections on the wifi clients, and I'm pretty sure the wired LAN clients lose part of their connectivity sometimes too (maybe DNS).  The network printer is really unhappy and needs regular reboots in order to be able to print (even though it thinks it is connected fine), and the kids are now super unhappy as it is no longer possible to have a stable Among Us local game - clients getting dropped mid-game, or not being able to see the host without turning their wifi off and on again - the whole thing is just a mess.

 

Looking through these forums it looks like i'm not the only one, and it doesn't look like a firmware rollback is an option.  The thing that seems to fix most people's issue is to replace the router with a Huawei one.

 

Whilst this seems a bit of a workaround given I know that my previous sagecom wifi hub worked just fine, I think it is worth a try doing a router swap otherwise i'm going to have a family mutiny on my hands.

 

Is it possible for one of the TalkTalk support team here to arrange for a Huawei router swap so I can test it please?

 

Many thanks

 

Rob 

0 Likes
3 REPLIES 3

Message 1 of 4

Hello,

 

Please let us know how the connection compares 🙂

 

Thanks

 

0 Likes

Message 2 of 4

Many thanks Karl - fingers crossed!

0 Likes

Karl-TalkTalk
Support Team
Message 3 of 4

Hi

 

I'll get a Huawei Hub out to you to see if this helps.

 

Thanks  

 

Karl. 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

0 Likes