FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Weak wifi

Jo-37
First Timer
Message 7 of 7

My WiFi has been so weak lately and getting worse. Only a couple of devices can be connected at a time. I have 4 children needing to do in-line learning and have already used do much data as having to hot spot all the time. How can I boast the WiFi or do I need a new router? Broadband seems fine, speed good and wired connection to tv working great. But WiFi is shockingly awful! 

0 Likes
6 REPLIES 6

Message 1 of 7

Not neccesarily. If the problem is caused by WiFi interference, then no new router can help.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 2 of 7
Thanks Keith. I will give what you said a go, but will have to wait till later as busy now. I’ll let you know how I get on.
Also as router is quite old would getting a newer one be a good idea?
0 Likes

Message 3 of 7

Hi @Jo-37 

 

As @ferguson said, I can offer a lot of help with this sort of issue.

 

Slow speed, intermittent dropouts, breaks in the signal, or no signal on some or all devices, might be caused by Wi-Fi interference from other local networks, which can also lead to a permanent reduction in speed. No ISP can be responsible for your local environment, this is mainly a by-product of the popularity of Wi-Fi.

The HG633 is a dual-band router & offers both the older 2.4GHz & the newer 5GHz Wi-Fi bands. The problem is these are two different networks (SSIDs), but they share the same name, so you can't tell which one you are connected to. Log into the router (http://192.168.1.1) and enter a username of "admin" and use the unique router password (see the label on the rear of the router at the top).

Go to:-
"Customise my wireless network"

Append "5G" to the end of the network name of the "Wireless 5 GHz SSID" field. Then click "Save".


This will not fix your issues, but it will make it much easier to identify the band you are connected to. This way you will know which band is causing your problems.

Having said that, there is another approach which can be better, which is to use Band Steering. This will automatically move any 5G compatible device connected to the 2.4G band to the 5GHz band. This is available on the HG633 (V2.00), to enable it, first set both SSIDs to the exact same name. Then go to:-

Home Network > Wireless Settings > Enable Wireless Network Frequency Bands

 

Then put a tick against Enable Band steering.


Generally speaking, the 2.4GHz band suffers much more from interference than the 5GHz band, but the 2.4GHz one can sometimes have a better range, but this all depends on your local area.

You may then wonder what was really the point of this if it won't solve the problem? This is because the whole topic is too complex to be dealt with in one post. The next stage involves sending out a guide to you to help you get me some important diagnostic results, so as I can analyse them for you and recommend changes to your router configuration to solve them.

I only send this out to people who request it.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

Message 4 of 7

OK, to be fair that is quite an old model. Let's see what Keith has to say.

0 Likes

Message 5 of 7
It’s a Huawei-HG633 apparently.
0 Likes

ferguson
Community Star
Message 6 of 7

Which make/model of router do you have? 

 

We are lucky to have a resident expert in such matters: @KeithFrench can you help, please? 

0 Likes