FIbre Support

Get expert support with your Fibre connection.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Wifi hub

First Timer
Message 5 of 5

I have now tried two new Wi-Fi hubs. Each time they start off set to 'auto' for Wi-Fi channels but overnight they become fixed on one channel. However many times I reset to auto, they always revert.


Support Team
Message 1 of 5

Hi TD2020


Apologies for this.


I'm unable to connect to your router at the moment, is the router switched on?






Message 2 of 5
Yep, the behaviour is a bit illogical, but basically the default factory settings for the Sagemcom means it is effectively always on 'auto', because regardless of what you do with the channel settings the router will just override you and change it to whatever it thinks is best. If your Wi-Fi is performing fine then I'd just leave it as it is, it is only really necessary to ask the staff here to disable the Wi-Fi Optimisation if the router makes a bad decision with the channel it chooses and you want to specifically set it to a different one.

Message 3 of 5

Thanks. That makes sense. I'd assumed optimisation and auto were the same thing. Ie. Auto had to be shown for optimisation to work. The connection selected seems stable currently so I will monitor for a few days. Thanks for the info on how to access staff help, too

Community Star
Message 4 of 5

Hi @TD2020,


Have both hubs been the Sagemcom Wi-Fi Hub (the one with the bronze colour behind the holes on the front). If so, this has a feature called 'Wi-Fi Optimisation' that means it will change channel to whatever one it thinks is best, regardless of whether you have left it on auto or tried to select a specific channel manually yourself.


If you do have the Sagemcom then you could ask the staff here to disable the Wi-Fi Optimisation on your hub if you like, it would then remain on whatever settings you manually select.


However if you were just wanting to leave it on 'auto' then there is probably no benefit from asking the staff to disable this behaviour, as if it is on auto it will just select the best channel it can, which is exactly the same as it will be doing now using the 'Wi-Fi Optimisation'. However if you did want to select a specific channel then it would be worth asking the staff here to switch off Wi-Fi Optimisation for you.


For one of the TalkTalk staff on this community to be able to look into this you will need to update your community profile to include your name, landline telephone number that your TalkTalk service is provided on & an alternative contact number. This will allow them to identify you, and they will then be able to help.


Don't post any personal details in this thread, just add them to your community profile.


Then they will hopefully be able to respond to this post tomorrow.