FIbre Support

Get expert support with your Fibre connection.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

WifiHub connection problem

First Timer
Message 4 of 4

Hi all,


I thought I try my luck here with the issue I am having. We've been sent a new WiFi-Hub in order to be switched over to a fibre connection. Now the router does not connect to the internet, the white light never comes on.
We've been chatting to support last Friday and then sent an engineer round today who tested the line and it's all fine, but the router still does not connect.
The engineer thinks the router is either faulty or there is a configuration issue. I've connected the router via LAN cable to the old router which is working fine, and it does connect without problems.
So it does look like there is a configuration issue on the DSL side. I had a look at the settings between the new and old router, and the old one is set to PPPoA while the new one is expecting PPPoE. Could the issue lie here?
(The engineer btw thought the best would be to just switch on the fibre and it will probably work fine...)


Message 1 of 4

Hi jenku


I'm sorry to hear this.


Just to confirm, which router is currently connected to the line? The new router or your old router?






Message 2 of 4

I had another chat with the talktalk support and they now say the reason it doesn't work is because fibre isn't yet available in my area. Not sure how believable that is as we are quite central and why would they otherwise send out the router?

Yes we've tried resetting and literally everything but the DSL simply doesn't connect, while the old one doesn't so I do think there is a configuration issue on the other side here.


The router works fine plugged in via lan-cable into the old router and funnily the wifi is a little faster this way. 🙂


Community Star
Message 3 of 4

Hi @jenku,


There is a pinhole reset switch on the back of the router, if you hold that in for over 10 seconds while the router is switched on it will factory reset the router, the default factory settings are the correct ones to connect to the TalkTalk network.


Have you also ensured you have used the new cable and microfilter (if required) supplied with your new router when trying to connect the new router to your phone socket.


The TalkTalk staff on this community will also be able to help, they will hopefully be able to respond to this post within a working day or two.