FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ugraded to faster fibre broadband but getting same speed as my old connection

gasher
Popular Poster
Message 13 of 13

Upgraded from basic broadband to faster fibre connection. I am getting the same speeds no difference at all, and top top it off the phone line has stopped working so cannot make any calls

0 Likes
12 REPLIES 12

Message 1 of 13

Hi gasher,

 

I'm sorry for the delay. The fault is still under investigation with BTOR at the moment.

 

Thanks

 

0 Likes

Message 2 of 13

Hi gasher,

 

I'm really sorry to hear this. I've requested an update from our Network Team now and I'll let you know as soon as I receive an update back.

 

Thanks

 

0 Likes

Message 3 of 13

10 days now and issue still no resolved, still unable to contact my elderly parents I care for. Obviously TalkTalk are not bothered

0 Likes

Message 4 of 13

Hi gasher

 

This fault has now been passed to a BT Openreach line engineer to investigate further.

 

We should receive further updates within the next 48hrs.

 

Thanks

 

Debbie

0 Likes

Message 5 of 13

Hi gasher

 

Thanks for your reply.

 

I've escalated this fault over to our Network Team and I will post back on this thread as soon as I receive further information.

 

Thanks

 

Debbie

0 Likes

wilsonjg
Popular Poster
Message 6 of 13

I have a similar issue with speed but phone is fine.

 

Upgraded and nothing changes for days. Small print says 72 hours but in certain circumstances that could be longer.

 

Tried facebook chat and a call but neither provided answers, was told its 2 weeks despite it being in the small print its 72 hours. Also in the small print is they can bill you before its setup!

 

Live chat checked line and said no fault, and to continue from home then when home no one replied. started again this time said there was a fault. my phone and internet is working fine just seems like no one has done anything about it apart from start billing

Always check the TT small print
0 Likes

Message 7 of 13

Yes i have tried connecting 2 phones direct to the test socket and still no dial tone, it would appear that it was cut off when the fibre broadband went live.

0 Likes

Message 8 of 13

Hi gasher

 

Apologies for this.

 

Is the no dialtone fault still present if you test with a corded phone at the test socket, with the router removed from the line? I can then escalate this fault over to our Network Team for investigation.

 

Thanks

 

Debbie

0 Likes

Message 9 of 13
Yes my phone line has been completely dead since the upgrade went live 6 days ago. The phone is crucial to me as I care for my parents and need constant contact with them, what the hell is going on. I bet you still charge me for the service though?
0 Likes

Message 10 of 13

Hi gasher,

 

Line test is showing your router is in sync at 40Mbps, can you switch your router off for 30 minutes then switch back on and retest 

 

Is your phone line completely dead, no dial tone?

Chris

0 Likes

Message 11 of 13

Information supplied have been without a house phone for 4 days now, very frustrating as i care for my parents and cannot contact them

0 Likes

Debbie-TalkTalk
Support Team
Message 12 of 13

Hi gasher

 

I'm sorry to hear this.

 

Please can you update your Community profile to include your name, telephone number and alternative contact number, we can then look into this further (Please do not post this information on this thread)

 

Please bump this thread to confirm once your Community profile has been updated.

 

Thanks

 

Debbie
 

0 Likes