cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Amazon Alexa won't connect to TalkTalk Internet

Reply
12 REPLIES 12
Jwozny
First Timer

Hi,

 

I have problem with Amazon Alexa. Can't connect it to the internet over TalkTalk Fiber Broadband.

When I try to connect to WiFi at the end of the process Alexa app is displaying error that can’t register.

It’s working fine with mobile shared internet from EE and with BT Fiber, so that proves that Alexa is working fine.

I have D-Link router model DSL-3782.

What I tested so far:

  • TT Router replacement – the same error;
  • D-Link router reset to factory setting;

Do you have any suggestions?

Thanks,

Jack

 

KeithFrench
Community Star

What is the WiFi spec of this device? Please can you give more details about this unable to register error? You would not get that if you couldn't connect to the WiFi. Does it need to initiate a connection to some server, as that might be what is failing to register?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

AldridgeAndy
Super Duper Contributor

@JwoznyI have an Amazon Echo ( 2nd Generation ) connected to a 3782 without any problems at all.

 

Are you configuring your Echo via a web portal or the Android or iOS Alexa App?

 

From what I recall - you get your Echo in to Set-Up Mode.

 

Connect your device ( which must be initially on the 3782's WiFi ) with the Alexa App on it to the Echo's own Wifi - Choose the correct TalkTalk WiFi network within the Alexa App you want the Echo to connect to and then enter your WiFI Password then save settings ( sometimes obscured by the on-screen keyboard )

 

Your Echo will then configure itself, connect to your TalkTalk WiFi and the device you have the Alexa App installed on should also fall back to the TalkTalk WiFi to allow further configuration, linking to music, shopping and news accounts along with the installation of skills.

 

Hope that helps a little.

Jwozny
First Timer

Hi @AldridgeAndy

Thank you for the response.

I'm using Android to configure Echo but tested it on computer app and iOS app.

I went through configuration process about 20 times. 

Like you said:

I’m connecting to WIFI then to Echo WIFI, Echo starts configuration and stops on around 80% with error about connection problem.

Like I mentioned before it works well when I am connecting over my friends BT Fiber or share internet form my mobile EE network. That proves that application works well, and I follow all necessary processes.

 

Thanks,

Jack

 


 

AldridgeAndy
Super Duper Contributor

@Jwozny

 

Can you do a quick check of wireless settings?

 

Have you seperated the 2 and 5Ghz Channels ( I haven't  ).

 

I have default wireless security WPS/WPA2

 

WPA Type = PSK Value 

 

Totally off topic ... I thought the Alexa app left a lot to be desired compared to the Google Home app, but I did what it had to do for me.

 

If I remember correctly you've "pin hole reset" the 3782 to remove any custom settings "just in case"?

AldridgeAndy
Super Duper Contributor

@Jwozny

 

Crazy thought - My iOS devices all connect as Wireless AC as does my Echo.

 

If you have seperated the bands - just maybe that could cause an issue if the software isn't quite as good as it needs to be.

 

If you're back to factory default then I'm "stuck" without being there. Sorry.

KeithFrench
Community Star

Slow speed, intermittent dropouts, breaks in the signal, or no signal on some or all devices, might be caused by Wi-Fi interference from other local networks, which can also lead to a permanent reduction in speed. No ISP can be responsible for your local environment, this is mainly a by-product of the popularity of Wi-Fi.

However, other factors should be investigated first. When this happens, what are the lights showing on the front of the router? Do you have any wired connections & if so, how do they perform?

If you have the HG633, HG635, or DSL-3782 they are dual-band routers & offer both the older 2.4GHz & the newer 5GHz Wi-Fi bands. The problem is these are two different networks (SSIDs), but they share the same name, so you can't tell which one you are connected to. Log into the router (http://192.168.1.1) and enter a username of "admin" and if the HG635 a password of "admin" as well, or if the HG633 or the DSL-3782, use the unique router password (see the label on the rear of the router at the top).

HG633/635 go to:-
"Customise my wireless network"

Append "5G" to the end of the network name of the "Wireless 5 GHz SSID" field. Then click "Save".

DSL-3782 go to:-
Settings > Wireless (Wi-Fi)

Append "5G" to the end of the network name of the 5 GHz "SSID" field. Then click "Save".

This will not fix your issues, but it will make it much easier to identify the band you are connected to. This way you will know which band is causing your problems.

Generally speaking, the 2.4GHz band suffers much more from interference than the 5GHz band, but the 2.4GHz one can sometimes have a better range, but this all depends on your local area.

You may then wonder what was really the point of this if it won't solve the problem? This is because the whole topic is too complex to be dealt with in one post. The next stage involves sending out a guide to you to help you get me some important diagnostic results, so as I can analyse them for you and recommend changes to your router configuration to solve them.

I only send this out to people who request it.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Jwozny
First Timer

Hi @KeithFrench,

 

Thank you for your response.

 

I shout mention that I’m IT engineer with over 20 years of experience. I decided to post my Echo connection problem on this forum because I run out of ideas.  

Of course, on some point I renamed 5 GHz network, even more I disabled it. I made some tests on different router (TP-LINK N600) and had the same error. It looks like something is blocked somewhere else then on the router.

Thanks,

Jack

KeithFrench
Community Star

Sorry, I was just responding to the previous suggestion.

 

One other thought is that by default, TalkTalk has started actively blocking websites commonly used by Scammers to access a PC. I doubt if this will be what is blocking your traffic, but it is easy to temporarily disable this blocking to see if it is the cause of your problem.

 

This feature can now be disabled (at your own risk of course) by logging into MyAccount. Then go to:-


My Services > Broadband > View HomeSafe settings

In there turn off Scam Protection.

 

For more details please see:-


Manage HomeSafe settings help

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Jwozny
First Timer

Hi @KeithFrench,

Thank you for suggestion. I didn’t try that.

 

I turned off Scam Protection on my account. I tried to connect echo but no success.

 

I know that network settings propagation to all devices can take some time, so I will try tomorrow again and let you know.

 

Thanks,

Jack

123Adele
First Timer

Hello

I have been trying for over 4 weeks to connect my Echo to my home wifi.

I go through the Alexa app on my mobile with the Alexa in set up and get to the connect to Wifi, I come off my wifi on my phone and then click Amazon wifi enter my wifi password (exactly how it is on the back on my wifi box) but it falls to connect to wifi.

I am at a loss.....any help.  I brought the Alexa to work and entered the work wifi password into it and it connected straight away to prove it was not faulty at all.

 

123Adele
First Timer

I have been trying for weeks to connect my 2nd generation Alexa to my talktalk internet.

I use the app on my phone and go to wifi settings and find Amazon and then enter my wifi password but it will only get a quarter way through set up and fails to connect to my wifi.

To prove my Alexa was not faulty i took it to work and connected first time to BT Fibre with password.

I cannot get it to work and am not brilliant at IT and need some help please.

andrewneath
First Timer

I have exactly the same problem, this is definitely a talktalk issue, when I take the echo dot to a friends house, it instantly connects to their BT wifi. Come on talktalk fix this embarrassing problem, how difficult can it be.