cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Chromecast with WiFi hub

Reply
12 REPLIES 12
Hifh124
Chatterbox

I have the new talk talk WiFi hub and am trying to connect my chromecast to the new router but I can't get it to go through the set up in Google home. I have tried altering the security settings on the router and it still won't work. Can anyone help at all? 

ferguson
Community Star

Whereabouts in the setup process are you failing? Is the Chromecast network showing in the device you are using to set it up?

Hifh124
Chatterbox

I go to the Google home app and press on setup, but it never stops spinning, it never connects to the device? 

Hifh124
Chatterbox

And yes the chromecast network does show up on my phone 

ferguson
Community Star

Have you tried resetting the Chromecast and uninstalling/reinstalling the app?

 

I always find when swapping routers that it is easier to change the new router wifi settings to match the old one rather than resettng every single connected device.

Hifh124
Chatterbox

I only downloaded the app after I got the new router. I'm not sure how you reset the chromecast? It just keeps telling me to download the Google Chrome app and go through setup which is what I have been trying to do. 

ferguson
Community Star

There's a small button on it. Are other devices connecting to your router without issue? If so you may be do beet to look for help from Google rather than here.

Hifh124
Chatterbox

Thank you I will have a look for it and give that a try. Thank you for your help! 

ferguson
Community Star

No worries, keep us posted. I am sure it won't be much consolation, but I have just spent the last half hour or so struggling to reconnect my Amazon Echo Dot. Technology, huh?  

Bramleyapple
First Timer

I know it's a bit late for you Chatterbox but this may help others. I couldn't connect my 1st gen chromecast to my new talktalk wi-fi hub (hub 5364). The Google Home app (on an iPhone) kept telling me it couldn't find my chromecast.

After googling for quite a while I found that the following worked. Turn on your chromecast. On your iPhone go to settings -> wi-fi and where it says choose a network find your chromecast. Select your chromecast. Your phone will connect to the chromecast. Come out of settings. Go back into the Google Home app and follow the instructions to connect.

This worked for me on two 1st gen chromecasts.

Not sure if it works for andriod phones.

magalhaes
First Timer

Hi, could you try and help! I’ve purchased a new google chrome but when I try to connect it, it gives me an error about WiFi settings?? Help please! I’ve tried everything o can think of, even tried the TalkTalk tech help and it was of no use!! Thank you 

magalhaes
First Timer
Can you assist with me connecting? I’ve followed your guidelines and still get an error! ☹️
Bob000bob
First Timer

I am having similar experience but occasionally it does work after going through and rebooting (ie switching both the rooter and the Chromecast audio off for twenty seconds).  I then try opening Home a few times until it finds the chromecast device.  My suspicion is that the Chromecast can only receive the wireless on one frequency and that the router is switching to the "optimal"

frequency that the Chromecast cannot see.  That would explain the intermittent nature of my fault.  I also reckon that the Wi Fi signal is sometimes too weak, so getting both your phone and the Chromecast as close to the rooter as possible helps.  The Chromecast is defo working as in my Wi Fi settings on the phone it is visible but states no Internet connection suggesting either it is too far away from the signal or the rooter is not sending the right signal.  At this point I've run out of ideas and patience.  Other wireless devices in the house occasional get the same error message (no signal) so strongly suspect it's the rooter that is causing the problem.  Can anyone help please.  It is driving me nuts.