Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Connecting second router


I’ve just switched to Fibre broadband with the new WiFi hub.


My "old" DSL 3780 router has a USB socket which was very useful as it enabled me to connect my camera to the router and then to access photos on the camera from my iPad using the FileBrowser app.  

Is it possible to connect the two routers together so that I can still access devices connected to the USB? I’ve seen articles online talking about using a second router as a wireless access point but I don’t want to do that and would probably prefer to switch off the WiFi on the second router to prevent interference.

Community Star

Yes you can do, but please bear in mind that the USB port supports SAMBA V1 only which is very insecure.

I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

First Timer

Hi there. in my experience you can connect a second router without issue BUT you must turn off the dhcp function in the second router. To do that you have to get access to the second routers options page and un-tick the dhcp option. Doing that means the second router becomes a hub/link rather than a server for the internet. Router one will still deal with all that for you.It does work, I have done it myself with three routers!! If you want to you could turn off the wireless function on router 2. 


Finally got around to trying this and it worked successfully. I turned off DHCP and reset the IP address on the second router as as advised in a number of articles I’ve read online. FileBrowser on my iPad was then able to access photos on my camera connected to the USB socket on the second router.😀 Saved me splashing out £10 on a memory card adapter for the iPad as well as making some use of a semi redundant router.👍


One question - some articles suggested changing the IP address of the second  router to rather than Would that have worked also?

Conversation Starter

I'd recheck those articles, for internal networks you normally only use private IP addresses. these are:- – – –


Avoiding the 0 suffix


I suspect it meant to either use or (assuming your main router is on