cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Improve My Wifi Signal For TV

Reply
52 REPLIES 52
brbrown
Wizz Kid

I now have a Wifi enabled TV but my router is in another room on the opposite side of my bungalow. Consequently the signal at the TV is quite weak whilst the signal at the router is at full strength. Can anyone please suggest a way of increasing the signal strength to the TV?

KeithFrench
Community Star

So much will be down to the quality of that signal, not just the signal strength. By quality, I mean lack of Wi-Fi interference.

 

Slow speed, intermittent dropouts, breaks in the signal, or no signal on some or all devices, might be caused by Wi-Fi interference from other local networks, which can also lead to a permanent reduction in speed. No ISP can be responsible for your local environment, this is mainly a by-product of the popularity of Wi-Fi.

If you have the HG633, HG635, DSL-3782 or the TalkTalk Wi-Fi hub, they are dual-band routers & offer both the older 2.4GHz & the newer 5GHz Wi-Fi bands. The problem is these are two different networks (SSIDs), but they share the same name, so you can't tell which one you are connected to. Log into the router (http😕/192.168.1.1) and enter a username of "admin" and if the HG635 a password of "admin" as well, or if the HG633, DSL-3782 or the TalkTalk Wi-Fi hub, use the unique router password (see the label on the rear of the router at the top).

HG633/635 go to:-
"Customise my wireless network"

Append "5G" to the end of the network name of the "Wireless 5 GHz SSID" field. Then click "Save".

DSL-3782 go to:-
Settings > Wireless (Wi-Fi)

Append "5G" to the end of the network name of the 5 GHz "SSID" field. Then click "Save".

TalkTalk Wi-Fi hub

Go to:-
Dashboard > See Wi-Fi Settings > Manage Advanced Settings > Wi-Fi 5Ghz gear icon > Basic

Append "5G" to the end of the network name of the "SSID" field. Then click "Apply".

This will not fix your issues, but it will make it much easier to identify the band you are connected to. This way you will know which band is causing your problems.

Having said that, there is another approach which can be better, which is to use Band Steering. This will automatically move any 5G compatible device connected to the 2.4G band to the 5GHz band. This is available on the HG633 (V2.00), DSL-3782 (V1.10) and the TalkTalk Home Hub. To use this leave both network names identical and on the HG633 enable Band Steering from the initial Wi-Fi menu.

Generally speaking, the 2.4GHz band suffers much more from interference than the 5GHz band, but the 2.4GHz one can sometimes have a better range, but this all depends on your local area.

You may then wonder what was really the point of this if it won't solve the problem? This is because the whole topic is too complex to be dealt with in one post. The next stage involves sending out a guide to you to help you get me some important diagnostic results, so as I can analyse them for you and recommend changes to your router configuration to solve them.

I only send this out to people who request it.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

brbrown
Wizz Kid

Hello Keith. Many thanks for the reply. It all looks a bit complicated so allow me time to work on it and I will get back to you with the the result. Regards. Brian

brbrown
Wizz Kid

Hello Keith. My router only shows HG523a and the only reference I can find to SSID is in the Wireless Package settings under WAN. Connection Port Binding shows boxes for SSID1, SSID2 SSID3 and SSID4 with no ticks in the boxes.

It means nothing to me but on the Wireless Package page, it shows a Send error 2687 and Receive error 6074. Might that be something that needs attention?

I can't find any reference to DSL-3782 or TalkTalk Wi-Fi hub.

KeithFrench
Community Star

OK, you didn't say what router you have & the HG523a is now very old. I will ask the OCEs to consider replacing your router with something more modern. If you still have WiFi problems after that (it wouldn't surprise me as it is likely to be down to congestion in your local area) then let me know & I'll help further.

 

The forum is not real-time 24/7 support, so depending on how busy they are & how many are working at any one time, this can take 24 - 48 hrs (excluding weekends & limited cover on Bank Holidays). Alternatively, you can call the call centre or use online chat. The posts are responded to in time/date order, oldest first. So the fewer entries you make on your thread now, the sooner they will pick it up.

To save yourself time, please make sure that your community profile includes your first & last names, broadband phone number & if possible an alternative contact number. This can be done by clicking on your Avatar picture then click on "My Settings" followed by:-

Personal Profile > Personal Information

Otherwise, TalkTalk will not be able to tie up your forum username to your broadband account. Only you & TalkTalk have visibility of your details.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

brbrown
Wizz Kid

Keith, That's very kind of you to ask OCE on my behalf. Thank you very much. I will check my Personal profile and update where necessary.

KeithFrench
Community Star

No problem.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Community Team

Hi brbrown,

 

Is the HG523 the only router you've had from us? Do you currently have any other TalkTalk router (system shows the HG523 has been superseded by another device)? 

Chris

brbrown
Wizz Kid

Hello Chris. Thanks for the reply. Yes I also have an HG633 which Keith mentioned and which I was going to send back because when I installed it, my broadband speed reduced significantly. Normally I get  round 11 Mbps but I seem to remember that the HG633 reduced it by at least 25%.

Community Team

OK thanks. When did you last try the HG633? There have been recent firmware releases which could improve performance 


Chris

brbrown
Wizz Kid

Chris, I haven't tried it again but I will do so and let you the result. Brian.

Community Team

OK thanks Brian. if you let me know when you've plugged it in I can check the firmware version


Chris

brbrown
Wizz Kid

OK. I am now plugged in to the other router but I cannot get on the internet using wifi, only using the ethernet cable. In my network settings, I have ticked the Wireless Network Name and typed in the Wireless Password but a message tells me it is an invalid password. Am I using the wrong one?

KeithFrench
Community Star

Can you access the router's admin pages via a wired connection? If so go to:-

 

Home Network > Wireless Settings > Encryption

 

You will see the wireless password listed there.

 

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Community Team

Hi brbrown,

 

Your router doesn't have the latest firmware so are you OK if I try updating the firmware now?

Chris

brbrown
Wizz Kid

Keith, my apologies the password with a digit hard to see but Now sorted thank you.

 

Chris, yes please go ahead with the update.I will leave everything on.

Community Team

OK thanks, I'll do the firmware update now

Community Team

OK, the firmware update is going through, it may take a few minutes.

 

Chris

brbrown
Wizz Kid

Chris, I can't tell if the update has finished yet but my speed is now the same as my previous at 11Mbps but I cannot now login to my new router with any combination of usernames or passwords. i have also lost the wifi signal on my TV even though I have changed the settings to suit the new network. Any ideas please?

Highlighted
ukoldgit
Insightful One

Sorry to jump in, but if you get the wifi up and running then the best way to get the wifi to the TV is with a wifi extender, TP-Link RE200 is very good.

 

You'll need to find the best spot to plug it in and I find it's easiest to use Speedtest net on your phone. Stand next to the router do a speed test and then do one in the room with the TV and then walk towards the room with the router doing a speed test every 12 feet or so until you get a decent speed that is greater then room with the TV in and then plug it in to the nearest socket.

UK Old Git