cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Is anybody using Google Wifi succesfully ?

Reply
pgc30
Chatterbox

Yes you can have IP reservations.

 

The DHCP address range is by default x.x.x.20 to x.x.x.250, but can be altered and you can reserve some of these for specific devices/mac addresses. Otherwise for things where you want to set up the networking manually with static IP addresses you can use x.x.x.2 through x.x.x.19 aswell.

 

Separately you can then setup port forwarding rules for any of these aswell if you need them.

PGC
nrushforth
Chat Champion

Last question for now. 

 

I have 4 LAN ports on my current modem router as I need 4 things hardwired (NAS, Hive Hub, Sonos Bridge and a network plug)

 

I assume I can attach a 5 port switch to the Google WiFi and achieve the same?

 

 

pgc30
Chatterbox

Yes, I have an 8 port switch connected to the lan port on the primary node and another on one of the other Google WiFi mesh nodes. See the Google FAQ on this subject at: https://support.google.com/wifi/answer/7215624?hl=en-GB&ref_topic=6243113

 

PGC
nrushforth
Chat Champion
Brilliant. Many thanks for your quick reply on all my questions.
Lada_Dave
Participant

Afternoon All,

Can anyone provide me with an idiots guide to setting this up with my Talk Talk Dlink dsl 3782? I would like to still be able to see items hard wired to the routers 4 Ethernet ports and have the mesh network for all my Wi Fi items.

 

Thank You

Dave

Lada_Evans
pgc30
Chatterbox

Unfortunately that is not going to work.  The TalkTalk box is a modem and router combined. The Master Google wifi unit is a router. You don't want to get into a double NAT'ing setup with two serial routers, so the TalkTalk unit needs to be put into 'Modem only mode'.  When the TalkTalk unit is in 'Modem only mode' then its hardwired ethernet ports are either all directly open to the internet or disabled (other than the first). Having said that I never managed to get the TalkTalk unit into a proper 'Modem Only Mode' so that the Google wifi unit could successfully DHCP through it and out to the exchange. So I gave up and just acquired one of the old BT Openreach modems that TalkTalk and others used to provide. The Openreach modem requires no setup and the Google Wifi or other Mesh wifi router unit that you get will connect through the modem to the exchange to get it's WAN/internet side IP address from TalkTalk. For hardwired connections just buy a cheap switch and hang it off one of the ethernet ports on the Google wifi mesh units.  Hope that helps without being too technical.

PGC
Lada_Dave
Participant
Thank you. I am picking the google Wi-Fi kit later and will see what I can do.

Thanks Dave
Lada_Evans
KeithFrench
Community Star

No current TalkTalk router supports modem mode.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

charlesb224
Wise Owl

@KeithFrench 

 

Keith, in all fairness, terminology might differ, but essentially 'modem' mode or 'bridge' mode for layman is in essence passing the WAN address to a separate router.  It's a bit disingenuous to say that no current TalkTalk routers support that... officially no, unofficially .... yes they do.

 

In that sense, the DSL3782, and the HG635 can all be set to 'bridge' mode, removing NAT and having the downstream router obtain the IP Addresss via DHCP/Automatic IP 

HG633 - maybe it can. not tried it, but others have...  basically:

 

  • Change WAN connection mode to 'bridged'
  • Disable LAN DHCP Server on TalkTalk device
  • Optionally disable WIreless

Then set downstream router to Automatic/DHCP IP address connection, connect to LAN port of Talktalk router and voila....

 

Lada_Dave
Participant

Hi Charles,

 

thanks for for the response. This is what I did last night:

 

disabled wifi on my router and connected the google Wi-Fi to the router Ethernet port 1 and then anything that was in the other ports I have disconnected and put this into a Ethernet switch and then connected that switch to the spare Ethernet port on the google Wi-Fi. This is all appears to be working.

Do I need to do anything more? Is this sufficient? 

 

I did try this “bridge mode” but it didn’t seem to get me internet access on my WiFi connected laptop. Could it have needing switching off then back on after the changes had been made? 

 

Thanks Dave 

Lada_Evans
charlesb224
Wise Owl

If you want the Google router to have the Internet WAN IP address, you must disable the LAN DHCP Server on the Talktalk router AND set Bridge mode in the WAN Setttings.

 

Anything else will be NAT, which may not be what you want.

Lada_Dave
Participant
Hi Charles,

What is the benefit to doing the first option over leaving it as is (NAT)

Sorry but I don’t really understand

Thanks
Dave
Lada_Evans
KeithFrench
Community Star

Hi @Lada_Dave 

 

Whilst @charlesb224  is quite correct some may find this confusing and in deed, some people have had some success in manual modem configuration, let me explain a bit more about what I said.

 

  • Modem mode - this is where you pass on the public or WAN IP address allocated by the network via one of this router's (now modem) LAN ports on to a connected router. The router connected to the line now only functions as a modem, it has no router functionality at all. When I said that no current TalkTalk router supports this, I stand by that as there is no option called "Modem mode" available in the configuration options at all.
  • Bridge mode - this is where the second router also has its routing functionality removed & simply now acts as a "switch". This switches any packet on the same IP network from one port to another. Some people wrongly think that the initial router connected to the line should be put into bridge mode. If this is done, the WAN IP network is a totally different IP network to the local 192.168.1.0 network. The result of this is no device will be able to access the internet at all. The way to get this to work is to then use the initial router as a modem/router, handling all router functions.

 

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

charlesb224
Wise Owl

 @KeithFrench 

 

Well, we've had this interesting difference of opinion across many threads over the last couple of years.  OSI Layers and everything inbetween and nothing has really changed your view it seems :winkingface:

 

In both my opinion and experience, bridge mode in TalkTalk Routers bridges the VDSL connection to the Ethernet connection, thereby bypassing the TalkTalk Routers Routing ability.

This is in effect Modem Mode in all but name.  Why it's listed as Bridge mode in the router's WAN setup page I will never know.  But that is what it is.

 

That bridge enables a downstream router (in DHCP/Automatic IP/Dynamic WAN Setup) to pick up the Internet WAN IP Address

 

What doesn't help clarity of this is statements that you make indicating that the TalkTalk routers don't support Modem mode and the Bridge mode would mean nothing works.  That is clearly and demonstrably not true (and I sit here typing this on my computer, which is connected to my router, which is connected to a VDSL Router set to 'bridge' mode - current model being a TP-LINK ) 

 

charlesb224
Wise Owl

@Lada_Dave

 

The reason to not have NAT Is where you want to use Gaming capabilites, or VPN, or VOIP  where the service is tied to your Internet IP address.  If you have no need of any of these things, then you can just double-NAT by using your Google Wifi as normal, plugged into the TalkTalk router.

 

NAT  = Network Address Translation essentially is a way of allowing multiple devices on a network communicate with a single WAN/Internet IP Address.  All routers do this by default.  The trouble is when NAT interferes with one of the above services, and you want your Google router to have the Internet WAN IP address rather than the TalkTalk router.  That is when you need to switch the TalkTalk router to Bridge mode, AND you must must must turn of DHCP server in the TalkTalk router, otherwise, your google Wifi Router will still get a NAT address from your TalkTalk Router.  Turning off the DHCP server will allow the Google Wifi router to get the WAN IP address from the TalkTalk WAN DHCP Server.

KeithFrench
Community Star

I'm sorry @charlesb224 the reason I am not prepared to change my mind on this, is because it is a networking fact. A bridge is a layer 2 device, it cannot route packets to a different IP network, for that you need a router.

 

If I am wrong then so are Cisco Systems and many other IP networking manufacturers. Here is a definition of a bridge that I did not write:-

 

https://en.wikipedia.org/wiki/Bridging_(networking)

 

Sorry but the URL for the page I wanted on Wikepedia just does not seem to work, if I get a better one I will post back on here.

 

 

 

 

 

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

charlesb224
Wise Owl

@KeithFrench  Ah.... but you missed this HP gem:

 

"Because routers work at layer 3 of the OSI stack, they can 
transfer packets between different media types (leased lines, Ethernet, 
token ring, X.25, Frame Relay, and FDDI). Many routers can also function 
as bridges. "

 

https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-c00932929

 

So the router is functioning as a bridge between Frame Relay (or whatever is delivered via VDSL) and Ethernet...  

 

KeithFrench
Community Star

My last post on this subject in this thread. If I had a Cisco IOS router & wanted to turn it into a bridge, the first command you have to enter is:-

 

no ip routing

 

The moment you press return all routing functions are totally disabled and you have a bridge. Further configuration work is still required, but it turns a router into a bridge. A bridge is a layer 2 device that links up different sections of a network that are on the same IP network.

 

So if you use a bridge to connect the ADSL or VDSL to your local network, the public IP address could be something like (OK not realistic) 1.2.3.4, which is a totally different network to 192.168.1.0. You cannot route between these two different IP networks. This is NOT my opinion, but a networking FACT.

 

Hopefully, this link will work:-

 

https://en.wikipedia.org/wiki/Bridging_%28networking%29

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

charlesb224
Wise Owl

OK Keith, my last post too :nerd: we'll agree to disagree... experience trumps theory :nerd:

Lada_Dave
Participant

Hi All,

 

i have tonight turned bridge bridge mode in the router setting and disabled the DHCP server but once this is applied my Google WI FI stops working and states no internet connection? 

 

I know now I am clearly out of my depth and all help is very much appreciated. 

 

Thanks

Dave 

Lada_Evans