cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

TECKIN SMART PLUG - connection issues

Reply
6 REPLIES 6
Andy333
First Timer

Hi All,

Having spent some time trying to get my new set of 4 Teckin plugs to connect, today, I found the following helpful post on a BT forum.

I had also previously disabled the 5GHz band as suggested, allowed all devices on the MAC filter and checked the security settings were as recommended by Teckin without any success.

So, with full thanks to P_Rogers, this worked for me.

______________

Had previously switched off 5Ghz as having issues, they were still off when resolved)

To Add Existing Plugs to new router

While phone/tablet connected to the Wi-Fi

Download and Login to the Smart Life app via App Store

 

Power down the plug for 10 seconds

Power on the Plug

on the Plug HOLD down the button for 5s (flashes fast)

Then

Again on the Plug HOLD down the button for 5s (Flashes slow ) this is AP mode, which generates a Wi-Fi hub.

 

In the app select Plus to add device

Select Socket Wi-Fi

Enter the your WIFI password

Then switch to AP mode from EZ Mode (default) - top right corner of the app screen

Follow the instructions when asked to change network

Change the network to 'Smart life xxxx' (Generated by the plug so may be different names)

Press back (to app) and scan will find the plug and re-attach it to the network with its existing name

_______________

Interestingly, plugs 2 & 3 then connected with no issue with EZ Mode, without needing to go through AP but I had to resort back to this method for Plug 4.

I have since turned the 5GHz channel back on and all still seems to be well.

Hope it helps!

 

has hoque
First Timer

Thanks Andy 🙂

 

I've been trying to find a solution to this problem for the last 8 months. I've tried youtube, online posts, etc to no avail, thankfully by chance I searched and found this solution work and only 8 hours after you had posted it.  

 

The problem only arose when I changed to the new router (Feb 2019).

 

You need to ensure that you have 5G off or you have named the band separately as 2.4G and 5G in the router settings.

 

 

Ann williams
First Timer

How do you turn 5GHZ off ?

jlfaz
First Timer

This was really useful thanks BUT I still can't get past where it says to connect to the Smartlife hotspot - I can do this but then when I go back to the App the plug light stops flashing, the wifi reverts to my home wifi but the scan doesn't find the plug

 

I have checked that my wif is 2.4ghz and disabled the 5ghz network.

 

I am about to send these back but found this and was feeling hopeful but still failed at the last stage - any other suggestions please ?

Andy333
First Timer
Hi

Only other thing I missed first time round was the miniature and almost invisible check Tick box to confirm I had the slow flash (for AP mode although it’s the same for quick flash in ezy mode). Tick and press next to get through this stage. Hopefully the plug will then connect.
Andy333
First Timer

Connect to router, type http://198.168.1.1 to a search bar and you should get the log in page. Router user name is usually admin but it’s in the back of the router under the removable WiFi password cover. That’s where you’ll find the router password too. Once you’re logged into the router it’s on the WiFi tab.

Valmac
First Timer
Thank you so, so much for solving my problem. I have been trying unsuccessfully for 36 hours to get this smart plug to connect...and you solved my problem in seconds. Thank you for the easy to follow instructions.