cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

TP-Link Archer VR900 continuously drops connection

Reply
25 REPLIES 25
matd1971
Participant

I'm on the standard ADSL/VDSL TalkTalk broadband with TV package. I replaced my ageing Huawei wireless router with the TPLink Archer VR900.

Since changing over though, the internet regularly connection drops every 10 minutes or so. Looking at the 192.168.1.1 admin page for the VR900 the network map status shows "Disconnected" and the error about manually setting DNS.

I've tried setting it manually to different DNS'es like Google, OpenDNS, the TalkTalk DNS. It works for a few minutes, then disconnects again.

 

When I set it up, I used the auto settings wizard. Additionally I set up a bridge connection for the IPTV so I could use the YouView box.

 

Is it my hardware/router at fault or is theresomething I've not set correctly in the admin/software? My firmware is up to date.

Thank you

Victormeldrew666
Enlightened One

Tp link routers can be a little tricky to set up but once correctly configured operate without any problem.

I do wonder if perhaps your antivirus software is the problem - you can try turning that off for a few minutes to check this is not 

I would suggest that you do a pinhole (factory) reset and start from scratch given the problems you are having.

Try the quick setup wizard again. 

Do not at this stage bridge iptv - generally with tt tv only enabling igmp snooping is necessary - the iptv stuff is usually for other countries who deliver iptv under different protocols. 

E.g I have the original 6 channel sky boost and have never needed to enable iptv on my router (netgear d7000 - full 80/20).

See how that goes and we can take it from there. (Get t'interwebs working properly first - then worry about anything else.) :winkingface:

matd1971
Participant

Thank you. I've just done a factory reset. Everything seems to be working ok (touch wood) apart from the TalkTalk TV services, which can't connect. What do I do next?

matd1971
Participant

Well...the connection only lasted for 5 minutes before disconnecting. With the following message:

Internet Status: disconnected

Please configure your DNS manually

 

Is it a faulty router? Is it TalkTalk? Losing my mind here because I use my connection for distance learning and I'm yet to have a connection that holds out for the full duration of my lectures 😕

ferguson
Community Star

You say ADSL/VDSL in your first post, which is it?

matd1971
Participant

Hello Ferguson,

 

I'm not sure which - all I know is it's not fibre broadband. How do I find out which it is?

matd1971
Participant

When I ran the TPLink setup wizard, the only option was for ADSL

ferguson
Community Star

Right, instead of using Quick Setup select Basic at the top then Internet on the left.

 

Select  Other at the bottom of the ISP list.

 

Click the ADSL button.

 

Tick the box next to Enable VLAN ID.

 

Enter 101 in the VLAN ID box.

 

Select Dynamic IP from the Connection Type dropdown menu.

 

Hit Save.

 

 

 

matd1971
Participant

That killed my connection completely. Also, I'm not given the option to configure VLAN and Dynamic IP when ADSL is selected - I have to select the VDSL button.

 

When saving the new configuation, a pop up appeared "Are you sure to delete the conflicted configuration?" - I had to answer "yes" to proceed.

 

Thereafter, the internet status changed to "disconnected" and the error on the Basic > Network page read "Please check your phone cable is connected properly"

IP Address, DNS Server and Gateway all showing as "0.0.0.0"

 

 

ferguson
Community Star

OK, sorry about that, can you confirm the software version?

Victormeldrew666
Enlightened One

Did you check in Advanced > Network > Lan Settings that the DHCP "enable" box is ticked and that the dhcp server box has been selected?

If not you will need to.

You may also need to enter other settings.

Under primary DNS enter 8.8.8.8

Under secondary DNS enter 8.8.4.4

 

Hopefully this is the issue - can you confirm your connection is adsl (not vdsl2/fibre)?

 

 

matd1971
Participant

Here's the details:

Firmware Version:0.1.0 0.9.1 v0069.0

Build 160525

Rel.38143n

Hardware Version:Archer VR900 v2 00000000 

ferguson
Community Star

OK, it looks like you have the most up do date firmware. Looking at the TP-Link emulator I am struggling to find the right settings for you with an ADSL i.e. non fibre connection.

 

Can you try this and see what happens?

 

Screen Shot 2017-07-12 at 20.46.10.png

matd1971
Participant

Hi Victormeldrew666,

 

My connection type according to Advanced > Status > DSL is "ADSL_2plus" - I definitely don't have the Fibre service.

 

I've followed your instructions to set the DNS servers to the Google ones (8.8.8.8 and 8.8.4.4), though the Status page shows that my DNS servers are set to 79.79.79.79 and 79.79.79.80

Do I need to resolve that conflict?

 

Incidentally, in the Advanced > Network > DynamicDNS settings page, the radio button for DynamicDNS is selected and my TalkTalk username/password is autofilled, but the status is shown as "disconnected" so I don't think that I'm logged into the DynamicDNS service.

 

Thank you

matd1971
Participant

Hi Ferguson,

 

It doesn't work when I change it to "Dynamic IP".

I get the message asking if it's OK to delete the conflicted connection, then status shows "Detecting..." before changing to "Disconnected" after a few seconds 

ferguson
Community Star

OK, try PPPoA with your TalkTalk login details?

matd1971
Participant

PPPoA with my login details is what I already have setup.

ferguson
Community Star

Well I'm stuck there I'm afraid my friend, all out.

 

If TP-Link have sold you that device on the basis that it it will work with your TalkTalk service then you should go to them to make it happen. And if they can't help then send it back for a refund, obviously.

matd1971
Participant

Just spoke to Amazon about replacing this router and they said that they've pulled it from their store because other people have also had the same issue 😕

So, does anyone have any suggestions for an alternative router I could buy that's cmoparable in features and as easy to setup?

Gondola
Community Star

Hi @matd1971

 

If your ageing Huawei router is not an HG635 or HG633 then why not call 0345 172 0088 and ask for a Super Router?  It's free, it's supported by TalkTalk and if you have any issues with your service then TalkTalk will ask you to connect a TalkTalk supported router to the line in order to be able to help you fully.

Claim a super router (Click here) scroll down to the small print and click on Super Router.


Call to claim a super router.jpgClaim a Super Router

 Gondola - Community support team

 To appreciate my help  . . .  If I offered a solution Best Answer