Home Phone

Get help with your TalkTalk landline and calling features.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Landline works via test socket-now what?

Sara82
First Timer
Message 5 of 5

My landline has had no dial tone but my broadband has been fine. I followed the instructions to sort the landline issue and it works when plugged into the test socket. What therefore is the issue? Do I need a new cable from my landline to the microfilter? Or is it a problem with the faceplate? The instructions ended at testing it so not sure how to proceed now....thank you

0 Likes
4 REPLIES 4

Message 1 of 5

Hi

 

glad you've got this sorted, thanks for leting us know.

 

Regards,

 

Karl. 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

0 Likes

Message 2 of 5

Thanks for your tips-it was the adsl in the end, had a spare so swapped it and saw it had a small tear in the wire...all sorted now thank G-d. Thanks again 

martswain
Philosopher
Message 3 of 5

@Sara82  do you just have one socket in your home and does the faceplate have one or two outlets ?

 

If it's just the one socket with one outlet and the phone works in the test socket, plug your microfilter into the test socket, then the phone in that and check again, that will eliminate a faulty microfilter.

 

If you have extensions wired into the back of the faceplate check that cable is not damaged anywhere in your home as it could be causing the issue as could faulty equipment connected to an extension.

 

 

 

 

0 Likes

Gliwmaeden2
Community Star
Message 4 of 5

For staff to identify your account, @Sara82, please add your Talktalk landline number to your community forum profile details. 

 

You need to go via your avatar/name; settings; launch profile wizard. 

 

The issue should receive a response from staff in the next day or two. 

Gliwmaeden2, a fellow customer.
0 Likes