Home Phone

Get help with your TalkTalk landline and calling features.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

My landline phone does not ring when bank or credit card company does automated call to verify

Barney7
First Timer
Message 5 of 5

My landline phone does not ring when bank or credit card company does automated call to verify. Can anyone help? (I choose not to have a mobile phone, and their using my landline for automated messages was/is critical to this lifestyle choice of not having a mobile.) It occurred to me that there might be some 'automated/mechanical blocking service' to prevent robocalls etc, but I'd urgently need to be eble to turn these off when doing a transaction that requires an automated call. THANK YOU for any guidance!

 

0 Likes
4 REPLIES 4

Message 1 of 5

Hi Barney7, martswain has given you absolutely perfect advice. 

 

Please let us know how you get on. 

 

Ady


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


0 Likes

Message 2 of 5

In your online account hover over or select MY SERVICES and the options appear.

 

MANAGE CALLSAFE and MANAGE HOME PHONE BOOSTS are in the list.

 

Anonymous Caller Reject is in the Home Phone Boosts list.

 

Call Rej.png

 

 

Message 3 of 5

Thanks so much Martin! I looked everywhere but could not find 'anonymous caller reject' or the other titles you mentioned anywhere on my account pages. ALSO, for information: There has been no problem with perfect strangers calling, it's the banks' and credit card companies' AUTOMATED calls (for example to give a passcode for a transaction) that do not work. The phone does not ring, and I'm unable to get the automated call. . . . Thanks for any guidance and a good, safe day ahead!

0 Likes

martswain
Philosopher
Message 4 of 5

Go to your online account and check Anonymous Caller Reject is turned off.

 

Check your CallSafe settings.

 

When making changes in your account, makes sure pop-ups are allowed as you will need to see the confirmation dialogue box.