Home Phone

Get help with your TalkTalk landline and calling features.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No landline, broadband fine.

Poppy13
Popular Poster
Message 14 of 14

I seem to have exact problems as lots of others. Landline sounds engaged, no dialtone, no incoming calls.  'Chat' to TT totally useless. Just spent 2 hours messing about checking all our in house equipment when asked by them.  Don't seem to want to send anyone out to check as they say no fault showing on their line from exchange.  What do I do now. Help.

13 REPLIES 13

Michelle-TalkTalk
Support Team
Message 1 of 14

Hi Poppy,

 

Thanks for the update and I'm glad to hear that the fault has been resolved. The ringtone issue was also a known issue which should have been fully resolved by 7th May.

 

Thanks

 

0 Likes

Message 2 of 14

@jomongeorge123, to receive help from TT staff on the forum, you need to start your own thread. 

 

Staff only reply to the original poster. 

 

Please go back to the message board and click on start a topic.

 

Staff will need to identify your account. You must add your Talktalk landline number to your community forum profile details by going via your avatar/name; settings; Profile Wizard. 

 

Once you have created your thread, look out for a response from staff during the week. They reply Monday to Friday and it can take a couple of days or so to reach new threads in the queue for attention. 

Gliwmaeden2, a fellow customer.

Message 3 of 14

I have the same problem for last 3 weeks and informed them but of no use. They have neither sent an Engineer as of today despite of my repeated requests nor fixed the problem.

0 Likes

Message 4 of 14

Hi Debbie

Update

Open Reach came today and at first thought it was our phone at fault but after checking connections outside and in the box (sorry don't know what they call it) on the street, he replaced some connectors and miraculously our phone works.  Even though TT said there was no fault on line there clearly was a problem.  The other strange thing is that we've had a funny ringtone for a few weeks, presume it's a TT update but that is now back to normal. Thanks for your help.

Message 5 of 14

Hi Poppy13

 

You're welcome 🙂

 

Please let us know how you get on following this visit.

 

Thanks

 

Debbie

Message 6 of 14

Thankyou Debbie.

Message 7 of 14

Hi Poppy13

 

Thanks for your reply.

 

I have arranged the Openreach engineer visit for 07/05 AM (8am - 1pm) This was the first available appointment.

 

Please let us know how you get on following this visit.

 

Thanks

 

Debbie

Message 8 of 14

There was nothing on the form for me to confirm charges. If it is found to be a fault in my property I will have to pay but this isn't,  as lots of others have the same problem.

I am available whenever, as soon as they can come out. 

0 Likes

Message 9 of 14

Hi Poppy13

 

Thanks for confirming your details.

 

Please can you also confirm potential engineer charges and provide your availability for this visit?

 

I can then arrange the engineer visit.

 

Thanks

 

Debbie

0 Likes

Message 10 of 14

Hi Poppy13

 

I'm just sending you a Private Message to confirm some details so we can arrange an engineer visit.

 

Thanks

 

Debbie

0 Likes

Message 11 of 14

Debbie, is this something you can sort for me ?  I just don't know whether I have to report it elsewhere or are you dealing with reporting to an engineer ? 

This is so frustrating.  

Thanks

0 Likes

Message 12 of 14

Yes I have done that. This seems to be the same problem lots of others have.  Is this a known issue ? Please get someone to sort this problem for me.

0 Likes

Debbie-TalkTalk
Support Team
Message 13 of 14

Hi Poppy13

 

I'm sorry to hear this.

 

I've completed a line test which hasn't detected any faults - Line test is clear.

 

Can I just check, have you tested with a different phone at the test socket, with the router removed from the line?

 

The next step will be to arrange an engineer visit.

 

Thanks

 

Debbie

0 Likes