Home Phone

Get help with your TalkTalk landline and calling features.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

hope someone can help

laine1958
First Timer
Message 6 of 6

i have wifi and landline with talktalk my contract does not end till feb 2021

but i dont use the land line at all for incoming or outgoing calls it just went dead tried all the suggfestions but nothing has helped i really cant afford to pay for an engineer so i am managing with out it using mobile phones as we all have one . . .the wifi is ok for the most part but i am paying for home phone that i never use

Elaine and the dogs
0 Likes
5 REPLIES 5

Message 1 of 6

 

Hi @laine1958

 

I can see that we have requested an engineer to go out to the exchange in the next 48 hours. 

 

We can check the fault ticket on Wednesday  for an update

 

Regards
 

0 Likes

Message 2 of 6

Hi  @laine1958

 

I will run some tests and get back to you. 

 

 

Regards

 

0 Likes

Message 3 of 6

OK, if the problem persists with just a handset plugged into the test socket then this will indicate an external problem and the question of an engineer charge should not arise.

 

Subject to that, if you would like the online support team to look into this for you make sure that your personal details including TalkTalk landline number are complete on your community profile here so that they can link your forum identity with your account and then wait for them to respond.

 

0 Likes

Message 4 of 6

it was working and i was using it but it has no dial tine or anything now so i have not been using it i could get an engineer out as ive done everything suggested , but i am really not keen on paying for an engineer i think i best ring talktalk off my mobile see what they say but i dont really need the land line im just paying for it 

Elaine and the dogs
0 Likes

ferguson
Community Star
Message 5 of 6

I am a wee bit confused by your post to be honest, you say you "don't use the land line at all for incoming or outgoing calls ," but it has gone "dead." How did you notice? Is there no tone on the line at all? Have you tested the handset connected directly at the master socket, or test socket if you have one?