cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Homesafe Kidsafe Not Working

Reply
8 REPLIES 8
Highlighted
Popular Poster

Hi I was advised to start my own thread on this one if it's not resolved by this evening I will unfortunately have to cancel my services.

 

Hi we just joined TalkTalk on friday switched on kidsafe and thought all was well and that it would be like the BT safe guards. Tonight we decided to test it and were appalled that even though its clearly ON in our settings it didnt block any adult constant at all. Absolutely disgraceful and we are reporting this. Very upset about this

Highlighted
Community Team

Hi Scoot1, thanks for posting in a new thread. I've got to ask have you tried turning kidsafe off and then on again? If you have then have you also turned the router off for an hour to force an IP reset? It will help us investigate if you can let me have 2 or 3 sites that you know get through. 

Highlighted
Popular Poster

Thats the first time I had this suggested turning it off for an hour. We were given 3 different stories from customer service agents last night who evidently just wanted rid of our query. We've decided to ask to go back to BT and our asking them for options. The garbage sites were just chosed at random. BT can do this no problem Talk Talk evidently can't its a breach of their contract as far as I can see very disappointed

Highlighted
Community Team

This should be a pretty easy fix and if you change your mind please let me know so that I can help. 

Highlighted
Popular Poster

Hi Ady many thanks for this I would certainly like this issue resolved as there is still nothing being blocked,

Highlighted
Community Star

Just a thought: are you using your newly supplied TalkTalk router with auto DNS?

Highlighted
Popular Poster

Yes just straight out of the box plugged in. None of the TalkTalk advisors have mentioned anything about the router though

Highlighted
Community Star

No worries, just a thought about the DNS servers that's all.

Highlighted
Community Team

Great let's get you sorted. Have you turned Kidsafe off and on again? Did you turn off the router? If you have let me have a couple of sites it's letting through. I also need the IP address, you can get this by going to google and typing What's my IP. Don't post that, send it to me in a personal message. Once we've done that I can get the team to investigate further.