cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Weak security message - solution doesn't work

ANSWERED
Reply
9 REPLIES 9
Highlighted
Sightseer

I have followed the instructions given to resolve this problem but I do not get the same options when I log into my router.  My router is a D-LINK so when I log in, using the username and password on my router I am given the options of selecting WPA/WPA2, WPA2 or WPA  

WPA2-PSK is not given as an option. So I have selected the WPA2 mode and saved it but then nothing happens.  I cannot see anything about Encryption.  Can anyone help please?  Thank you

Highlighted
Community Star

Which D-Link router model do you have?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Sightseer

Hi Keith

I think it is DSL 3680 - does that sound right?

Thank you

Highlighted
Community Star
Solution

My instructions only applied to the DSL-3782, your router is much older and a totally different UI. Go into Advanced mode & then go to:-

 

Setup > Wireless Setup > Manual Wireless Network Setup

 

In the WPA section, set it to WPA2 Only. Note it does say that this will use AES encryption:-

 

3680 wpa2.png

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Sightseer

Thank you for your reply however when i checked these settings are already selected.  I think I need to speak to Talktalk about a new router as we are also experiencing slow network.

Thank you for your help

Highlighted
Sightseer

Hi Keith

While I was waiting to get through to Talktalk I checked my phone and the weak signal message has disappeared !! So, thank you very much for your help. You've succeeded where Talktalk had failed! Much appreciated

Highlighted
Community Star

Please be aware that none of this was TalkTalk's fault. This is just a warning message from Apple just because TalkTalk make their routers more compatible with modern & older devices. However, the security settings are negotiated when a device tries to connect to your WiFi and unless you have anything old, they will still use WPA2 Personel with AES encryption. All Apple are moaning about is that you have the choice. All my configuration does is remove that compatibility with older devices. So it is now possible that some devices of yours may no longer connect to the router.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Community Team - TT Staff

Hi Fennymum, KeithFrench has done a great job of helping you with an Apple device after it's been updated. Please be sure to mark the post that helped you most as the best answer this will help other Apple users figure out the change.

 

Ady


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


Highlighted
Sightseer

He sure did.  Of course, sorry I'm new to all this . Thanks

Highlighted
Community Team - TT Staff

No need to apologise. We like to  encourage members to recognise the support from others and the best answer is the best way to do that and to lead other members to the answers.

 

Ady


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.