cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Scam protection and supersafe boost now off, still can't connect to Splashtop Business or TeamViewer

Reply
3 REPLIES 3
Juju49
First Timer

I spoke to customer service advisors three times last week 

Scam protection and supersafe boost are now supposed to be off.

I still cannot connect to Splashtop Business ir or TeamViewer. 

A colleague stood on my drive and used his phone as a hotspot, connected straight away.

Looks like talktalk is the problem.

,

simonb
Community Team - TT Staff

Hi @Juju49 Can you try these steps from Using a VPN 

  1. Turn on Kids Safe  in My Account
  2. Select Choose which websites to block and allow
  3. Add the website url and select Allow
  4. When you have added the sites select Save changes.
SimonB
StephenF
Community Manager - TT Staff

Hey, 

Sorry for the delayed reply, we're doing our best in these unprecedented circumstances due to the Corona virus to answer everyone as quickly as possible. I'm pleased to confirm that your now able to manage Homesafe settings yourself, from within my account, please follow the below steps to disable scam protection on your line: 

  1. Log into MyAccount
  2. Select My Services
  3. Select View HomeSafe settings
  4. Select OFF and confirm when you see the pop up window

Thanks 

Stephen, Community Manager


Our latest Blog l Share your Ideas l Service Status l Help with your Service l Community Stars l Set your preferences


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


theavvys
Chatterbox

I have exactly same problem - teamviwer will not connect through taltalk.

 

I can connect pc to another network and works fine - looks like talktalk is not letting teamviewer see the proxy settings

 

I have turned safe whatever its called off as well