Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

kidsafe is turn of in my account yet it still blocking my vpn and various sites why?

First Timer

kidsafe is turn of in my account yet it still blocking my vpn and various sites why?


i got to say this after talking to tech depart by phone twice! i feel the service is pretty poor!

ever since the upgrade due to changes in the law regarding data i had problems and i feel in my opinion, that talktalk are trying to rectify the security breach in data a while back and they have rushed the process and have not fully tested the new updates.

I was trying to connect to my VPN service provider-Frootvpn via there .exe application being blocked and not able to access throught any browser https.

as an after thought i removed the s and bingo a webpage produced by TALKTALK says i need to turn of or adjust setting in KidSafe.

accessed my account after some searching found the setting and they were all of; which is my prefered setting.

i switch it on and put an exception in no joy then turn it off.

the only opption left to me as my contract has expired is to find another service provider. I got a feeling this is going to take months or may be a year or two to resolve. TALKTALK history when resolving issues is poor and very slow, comunication is poor.

i generally feel that the internet has gone done the path of too many restrictions in the guise of safty and behind it is money and licencing fees pushing out the small buisness and allowing the big boys to control the market.

reminds me of corner shops, butchers, greengrocers etc and suppermarkets i notice the selection of goods in supper markets has slowly phased out to maximise profits and simplyfie stock.

It basically control of the market place.

please reply as I like loading the gun and rocking the boat.


Dave one *@#][!![]'#[@#]!* of customer and not impressd


We are not amused 

Community Star

Hi @davelynne


If you're not taking advantage of the security features of HomeSafe / KidsSafe then test with the workaround of using a different DNS setting in the router.


Try the secure Quad9 DNS: Primary and Secondary or Google DNS: Primary and Secondary (or a combination of Quad9 as Primary and Google as Secondary)


To change the DNS settings in your router, follow these steps:

  • On a device connected to the router
    Open a Web browser, type into the address bar
  • Tap Enter/Return
  • Enter the username and password and click OK
    Note: The default username is admin (all in lower case).
    The router password is printed on the label on the back of the router.
  • HG633 router password - top of the label
  • DSL-3782 router password - middle of the label to the left of the bar-code
  • Sagemcom FAST 5364 router password - under the pull-up wireless password card on the label directly above the S/N barcode.


For the HG633 router

  • Select Internet (top blue bar)
  • Select Internet Connection and then the grey Edit button
  • Scroll down and tick the Static DNS box
  • Enter the preferred Primary DNS numbers
    Enter the Secondary DNS numbers
  • Click the Save button
  • Scroll up and click Logout (grey button top right)


For the DSL-3782 router

  • In the Web browser address bar, type
  • Tap Enter/Return
  • Tick 'Use the following DNS Server Address'
  • Enter the preferred (Primary) and alternate (Secondary) DNS addresses
  • Click the Save button


For the Sagemcom FAST 5364 router

  • From the Dashboard
  • Select See internet settings
  • Select Manage advanced settings
  • Select the Internet Connectivity icon
  • Select IPv4
  • In the DNS drop-down box select Manually Specify DNS
    DNS1 enter the Primary DNS
    DNS2 enter the Secondary DNS
  • Click the Apply button

If you subsequently choose to return to the TalkTalk DNS the numbers are and


Here is the TalkTalk advice and router setup needed for using a Third Party DNS (Click here)

 Gondola - Volunteer 2017-2021

To appreciate my help . . . If I offered a solution Best Answer