NEED SOME HELP?

We’re here 24/7. 365 days a year.
Ask questions. Find your answers. Connect.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Own Modem + Router configuration

olicer
First Timer
Message 3 of 3

 Hi,


I am a new customer, I recently switched from BT to TalkTalk. I had fibre with BT and I ordered fibre with TalkTalk (76/20).

I have my network setup composed of:

- TP-Link W9970 VDSL Router - to be used as Modem

- TP-Link Archer C8 - to be the Router

With BT I used to bridge the W9970, enable PPPoE on the Archer C8 and use BT generic credentials, end of the story.


Problems started to rise with TalkTalk, since the original FAQ and suggestions in the forums are wrong, at least for me. 

FAQs (here) tell to use PPPoA, and some discussions in the forum tell the same. Somebody even said that PPPoE is supported.

PPPoA is available only on ADSL mode, at least on my W9970, so I assumed FAQs were wrong.

On PPPoE (still bridging) I tried any possible combination of broadband username and password, TalkTalk account username and password, I even changed broadband password. I was getting an IP for a second and then disconnected. 

After that, I turned on the Super (no) Router provided by TT, went to Internet settings and found out the truth: no PPPoA/E, but Dynamic IP address.

Why this is not written anywhere? At the same time, I have found out that my W9970 has presets for every ISP, and for TalkTalk configures:

VLAN ID: 101

Connection Type: Dynamic IP (IPoE Dynamic IP)

And guess? It works.

So why official TalkTalk FAQs are wrong? Can you please update them so in the future this situation won't happen again?
Thanks.

 

Now the real issue I have:

I can configure the W9970 to get internet, and the Archer to connect to it. And that's obvious.

However, I can't get the W9970 to bridge and the Archer to connect to the internet. 
If I use Dynamic IP address configuration in the Archer I get a LAN IP address, and not WAN/ISP Ip address.


Is somebody able to advice? I can post any screenshot if required.

 

I know, it's not a big deal since I can enable DMZ on the W9970 (that's what I did), but I don't need two LANs.

 

Thanks.

0 Likes
2 REPLIES 2

Message 1 of 3

Thank you very much sir, I didn't though it was that easy!

I have now successfully setup my W9970 as bridge and the Archer C8 is handling everything within a single LAN.

 

That's the configuration I have used, it could be useful for others:

TP-Link W9970

VLAN ID: 101

Connection Type: Bridge

Wireless: Disabled

DHCP: Disabled
(anything else is disabled, like Firewall)


Archer C8

Connection Type: Dynamic IP

MTU: 1500 (default)
DNS: 8.8.8.8, 8.8.4.4
(Google DNS servers, optional)

 

I get full speed (as I did with BT previously) so I am really happy now with the bridge configuration back to work!

 

Speedtest

Thanks again.

0 Likes

charlesb224
Wise Owl
Message 2 of 3

You need to turn off LAN dhcp server on your w9970.  Unfortunately the Dhcp request from your archer is hitting the w9970 and getting an allocation from its LAN pool rather than the wan.