cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

HG533 - Wake on LAN problems

Reply
13 REPLIES 13
superdjsi
First Timer
I'm trying to get WOL to work from the internet on my HG533 router.I've set up port forwarding for TCP\UDP on port 7 and have added a static MAC - IP mappiing for my PC (using arp -s from a telnet session to the router). I've also checked the forwarding using a WOL sniffer, this logs the WOL packet from the LAN but nothing from the web.
I've seen from another user that the static IP - MAC setting should work.

Any help would be appreciated:)
OCE_Chris
Community Team - TT Staff
Hi superdjsi,

Welcome to the forum

I have moved your thread to the broadband discussion section so that other members can offer assistance

Chris
Fred_Sheehan
Philosopher
WOL uses UDP on port 9 and you need to forward it to the broadcast address for the subnet the machine is on, on a Huawei in standard config this is 192.168.1.255 (in the wake on lan packet it has the hardware MAC address of the network card in machine you want to switch on, so only that machine will respond to the broadcast ;))
Setting statics for WOL is unneeded and won't work as expected, before the machine is switched on and ARP has taken place the machine has no valid IP, all IP's (even statics) are still 'issued' by the router after the initial ARP handshake which also uses hardware MAC's to negotiate a valid IP!
EDIT: meant to say, you have also enabled this in the BIOS of the machine you want to wake up?
superdjsi
First Timer
Hi Fred

Thanks for the reply. I did try to set the broadcast IP in the Port Mapping but the router throws up a "The host IP address is invalid." error message.
Any ideas as to where I can set this - do you think I can do it from the CLI? BTW, the BIOS has the WOL setting enabled.

Cheers
Timmyboy
Team Player
I also have the same problem - LAN working ok, can't get external to work. I did have this working with Sky previously. Any help appreciated...
Birchcroft
Philosopher
Am I correct in assuming that you are trying to get the machine to wake when contacted from the internet, rather than another machine on the same LAN? If so then you will probably need to implement DynamicDNS (en.wikipedia.org/wiki/Dynamic_DNS) as unless you are a TalkTalk business customer you are unlikely to have been allocated a static IP address by TalkTalk. The use of DynamicDNS gets over the problem of the external IP address changing.
Timmyboy
Team Player
DDNS isn't the problem Birchcroft; I already use it for a web cam externally without issue. I can't figure out how to configure the HG533 to allow the broadcast WOL to come in correctly. Has anyone got this to work externally?
HaHaHaHaHaHa
Whizz Kid
First off, WOL can use any UDP port u desire it does not have to be 7 or 9 - I use 32145 and it works fine

Second, sending the packet to Broadcast is incorrect !

Send the packet to the actual IP address that the PC has been given either by static IP or DHCP.
You can reserve a DHCP address on the router to ensure it always gives the same IP to the same machine.

The arp entry in the router must be directed at the IP address and MAC address of the PC in question
on the relevant interface (ie. Eth1 or 2 or 3 or 4)

The underlying requirement is that the router knows where the MAC address of the PC is,
the actual IP address is somewhat irrelevant as the PC does not have an IP address while off.

You then send your WOL packet to the actual PC.


From outside the LAN the router Forwarded port rule will send it to the right IP address
and the static arp entry will route it to the right interface.

At least that's what I do.

🙂
Timmyboy
Team Player
THanks for the help 🙂

This is the bit I don't understand:

Originally Posted by HaHaHaHaHaHa
The arp entry in the router must be directed at the IP address and MAC address of the PC in question
on the relevant interface (ie. Eth1 or 2 or 3 or 4)


The only place I can see anything with options including the 4 lan ports is on the basic 'wan' section, where should I be setting up this arp entry?
HaHaHaHaHaHa
Whizz Kid
Yeah .. sorry but it does appear that as a user you are locked out of the arp table on the TT HG533 router. (HG523 as well)

I have my own router.

really sorry ..

Telnet may offer a solution but I can't help you there.
😞
dean Lincoln
First Timer
Here's how to alter the arp table. I got this from another post and it works for me. However please note if you reboot your router the arp setting has to be made again as it will be lost.

I have WOL working fine from the internet I just wish the DDNS would work with www.no-ip.com. Everything I tried using the router DDNS facility wont work so I have downloaded the client side software No-ip provide but this is a pain as no ip update when client machine switched off.

Hope it helps

Dean

I finally managed to get remote Wake on Lan working on the EchoLife HG532.

The trick like on my TP-Link router was to set up a permanent ARP entry for the MAC address of the PC I wanted to wake up.

I was stuck because when telnet-ed to the HG532 router I was confronted with a ATP> command prompt, so I thought I could enter ARP ADD but this doesn't work.

N.B. please be aware that configuring your router like this is not how talktalk intend you to use your router and could cause it to cease working.

After logging into the router via telnet you need to enter 'sh' at the ATP command prompt, this runs BusyBox built in shell.
Then you can use the command arp -s 192.168.1.254 00:25:64:cd:f7:69
where xx:xx:xx:xx:xx is the mac address, and substitute whatever ip address you want.

When this is done type
arp -a
This should show you a list of IP addresses and their MAC codes, the one you just entered will have PERM on the same line.

Then from the router web admin configure the port mapping rule
www.pcwintech.com/files/scree...-hg532/013.png
Advanced --> NAT --> Port Mapping tab
Internal host is the IP address you supplied
Internal port will need to be 9 (or 7) external can be what ever (I should test with 9 also).
Leave remote host blank.

Use whatever tool you wish to send the magic packet.
I use an Android app, which works nicely.

I got the arp syntax from:-
www.busybox.net/downloads/BusyBox.html
Timmyboy
Team Player
Thanks for the info @dean Lincoln - much appreciated.

I think I've resigned myself to living without external WOL now - I find the HG533 to be quite flaky, needing a reboot quite often, so having to re-apply this every reboot would be a pain 🙂

Helpful to other readers though no doubt.
jcampy
Philosopher
Originally Posted by Timmyboy
Thanks for the info @dean Lincoln - much appreciated.

I think I've resigned myself to living without external WOL now - I find the HG533 to be quite flaky, needing a reboot quite often, so having to re-apply this every reboot would be a pain 🙂

Helpful to other readers though no doubt.


Ive never found it needs a reboot mines been up for 34 days atm and it's still fine
gogoud
Team Player

I created a program which can enable (or re-enable) wakeonlan (WOL, magic packet) for the TalkTalk / Huawei HG533 or HG532 routers. It runs under Linux or, with cygwin installed, under Windows.

 

HTH, Dominic