Showing results for 
Search instead for 
Did you mean: 
Need help?

Want to know how to get the most out of our community?

Hey, I'm Michelle and I wanted to tell you about our community and how it's packed full of useful information, answers and has a horde of active members waiting to help or just to say hey! We know forums can be a little daunting at times, so here are some of my useful tips to help you get the most out of the community:

Get Searching

Search is the quickest way to locate the information you're after, use the big red box above. If you don't find what you're after you can always post your own question.

Search now

Get stuck in

Prefer to jump straight into the community? Checkout the yellow "browse" tab over on the left hand side, here you'll find the entire community at your fingertips.

Try now

Join the party!

Had a peek around the community already? If so you'll no doubt want to join us, just hit register below and follow the instructions. Don't worry I'll still be here to help once you've registered.

Register now

Huawei HG520b - configuration problems!

Conversation Starter
Hi all,

I've been using the TT-supplied HG520b happily for the past three weeks (as a new TT member), and today tried at add another wireless device to my MAC filtering list. To my dismay, none of the "Submit" buttons on the router's setup pages work (I use the web interface to do the setups, I'd love to use another config method - other than a mallet - but I don't think there is one). I went along to the "Wireless" option, entered the MAC address I wanted to allow, clicked submit, but it did nothing. Not even a confirmatory "click" sound (the one I still get when I navigate through the options on the left side of the setup screen). I tried changing a couple of settings on other screens with a similar lack of success.

Now I know why its called a Submit button, 'cause I give up.

I set up 3 wireless devices when the router arrived, so it has obviously worked at some point in the past, I just can't figure why the buttons no longer work, is some ActiveX control now InactiveX? :) Or have I accidentally set some feature that locks out any changes to the settings? The third possibility has something to do with the quality of the router, has an acronym similar to "Point Of Sale".
It sounds like there may be an issue with the settings on your browser.

Have you changed any "Internet Options" settings recently ?

Are you using a different browser by any chance ?

Have you installed any new software recently ?

Have you changed any settings on your Anti-Virus or Firewall software if you have them installed / running ?
Conversation Starter
Originally Posted by BryanA
Have you changed any "Internet Options" settings recently ?

Are you using a different browser by any chance ?

Have you installed any new software recently ?

Have you changed any settings on your Anti-Virus or Firewall software if you have them installed / running ?

The answer to the first 3 is "no" - the computer almost never goes online (I use another computer for that).

The answer to the last one is "I switched off the firewall entirely to see if it was getting in the way" - and the answer to that was also "no".

I've just come back after a long power-down (yes, me too) to see whether its one of those "things" where a bit of hardware & firmware insists on doing things differently after a spell without power - then again, it did exactly the same. The button responds to "mouseover" events but is very unimpressed by a click. God knows what its done. I'll try it on other computers until I bore it into complying with my simple request!
Conversation Starter
Okay - I found a computer here that managed to get the router's attention. XP systems, Vista systems, Windows 2000, even Mac OSX 10.4.11 ... the router ignored them all. But my humble old Windows 98 box ... the dear old lady of our network ... sweet-talked it into doing what I wanted. Why, I'll never know. None of the other computers could do anything other than look at the settings. So the problem hasn't gone away, I just avoided it for the time being.

So, problem not so much fixed as sidestepped. I'd still be interested in opinions, especially if someone has had the same thing happen, because this old W98 box isn't going to last forever!
Conversation Starter
I had the same router sent to me and although this isnt going to help you, I found configuration a real problem setting up, for starters the pre programmed password was wrong, then getting the wep 128 bit encryption was becoming a joke.
I also couldnt seem to assign ip address to mac addresses.

Netgear all the way!
Conversation Starter
The pre-programmed pasword problem is a bit puzzling, no offence, but are you sure you read correctly what it should have been? Mine was fine.

To your other points, why use WEP? Its very insecure, and only if you have things like games consoles (or other equipment) that only support WEP should you use that system, far better to use at least WPA with AES or TKIP. After all your devices are recognised, you can then hide the SSID and hide your WLAN a little more.

A lot of people here dismiss the HG520b and I've yet to find any real reason to do so. I was happy with my Netgear DG834whatever but the new router is definitely on a par, to the point where the DG834 is now performing only as a network hub. I think for many people its a protective thing, where they claim to prefer the thing they know because it sort-of absolves them from having to learn about something else. I'd have preferred to have the DG834 as my Wifi centre because it is somewhat easier to set up, but not enough to make much difference.

Also, if you're using DHCP (are you?) then what are you doing trying to tie MAC addresses to IP numbers? The following day (under DHCP) your computer might end up with a different IP address and suddenly be unable to communicate because the MAC address for that IP would be "wrong". Networking is complicated enough as it is without inventing new problems!

If you want to fix all your IPs, that would be the only situation where it would be possible to do that kind of tie-up. Fixing a client computer name to a MAC address I can see the point of, but not IP unless every IP is set in stone.